]> code.ossystems Code Review - openembedded-core.git/commitdiff
x11-common: Fix unusable serial console
authorWolfgang Denk <wd@denx.de>
Thu, 27 Jan 2011 11:42:16 +0000 (12:42 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 28 Jan 2011 17:28:24 +0000 (17:28 +0000)
The serial console port is basicly unusable in images containing X.
Login works fine, but at the shell prompt only one out of N input
characters (N usually between 2 and 10) gets through to the shell.

dbus-launch (running as "dbus-launch --sh-syntax --exit-with-session")
is also reading from /dev/console and "eating" the missing characters.

As soon as I stop the Xserver ("sh /etc/init.d/xserver-nodm stop")
the serial console starts wroking fine (because dbus-launch is not
running any more).

This patch addresses the problem.

Signed-off-by: Wolfgang Denk <wd@denx.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/x11-common/x11-common/etc/X11/Xsession
meta/recipes-graphics/x11-common/x11-common_0.1.bb

index a87447a879ac493edc6b30e8f42fc1dd76dce238..0b73127ae11abff0ad645607d7a463a3c0d5e825 100644 (file)
@@ -2,7 +2,7 @@
 
 if [ -x /usr/bin/dbus-launch ]; then
     # As this is the X session script, always start a new DBus session.
-    eval `dbus-launch --sh-syntax --exit-with-session`
+    eval `dbus-launch --sh-syntax --exit-with-session </dev/null`
     echo "D-BUS per-session daemon address is: $DBUS_SESSION_BUS_ADDRESS"
 fi
 
index d15628560e739ce9a9492b1a30839bc30c7edb76..60b21c3b998f40b8ec2e613417a2e545089da937 100644 (file)
@@ -3,7 +3,7 @@ LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
 SECTION = "x11"
 RDEPENDS_${PN} = "xmodmap xdpyinfo xtscal xinit formfactor"
-PR = "r39"
+PR = "r40"
 
 SRC_URI = "file://etc \
            file://gplv2-license.patch"