]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa-7.10: set mesa 7.10 as default instead of 7.8.2
authorYu Ke <ke.yu@intel.com>
Wed, 9 Feb 2011 11:15:52 +0000 (19:15 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 9 Feb 2011 22:45:47 +0000 (22:45 +0000)
originally mesa 7.8.2 is set as default because 7.10
has depency of GPLv3 talloc. since mesa 7.10 has resolved
the GPLv3 talloc dependency issue, it is safe to set 7.10
as default

Signed-off-by: Yu Ke <ke.yu@intel.com>
meta/conf/distro/include/preferred-xorg-versions.inc
meta/recipes-graphics/mesa/mesa-dri_7.10.bb
meta/recipes-graphics/mesa/mesa-dri_7.8.2.bb

index 3a4bd335f718b5d67382c7bc163dde0a7a826111..b164b77f75862361a7f439674c49e558cfcba5e0 100644 (file)
@@ -135,7 +135,7 @@ PREFERRED_VERSION_xtrans-native ?= "1.2.6"
 PREFERRED_VERSION_xtrans-nativesdk ?= "1.2.6"
 PREFERRED_VERSION_xvinfo ?= "1.1.1"
 PREFERRED_VERSION_xwininfo ?= "1.1.1"
-PREFERRED_VERSION_mesa-dri ?= "7.8.2"
+PREFERRED_VERSION_mesa-dri ?= "7.10"
 PREFERRED_VERSION_libdrm ?= "2.4.23"
 PREFERRED_VERSION_xcb-proto ?= "1.6"
 PREFERRED_VERSION_libxcb ?= "1.7"
index 1984ff6a54b1caab2f710033d5084bec07c0b091..cca1cc967801bcf0d85828b51b00141a868364df 100644 (file)
@@ -8,7 +8,7 @@ LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat
 
 DEPENDS = "${PROTO_DEPS}  ${LIB_DEPS}"
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
            file://talloc-removal.patch \
@@ -20,6 +20,9 @@ SRC_URI[sha256sum] = "bcf28f43f39c28da271c0f5857fb32898d4ade3e035e80a0ceece1c2df
 # most of our targets do not have DRI so will use mesa-xlib
 DEFAULT_PREFERENCE = "-1"
 
+# Atom PCs have DRI support so use mesa-dri by default
+DEFAULT_PREFERENCE_atom-pc = "1"
+
 LEAD_SONAME = "libGL.so.1"
 
 EXTRA_OECONF += "--with-driver=dri --disable-egl --disable-gallium"
index 60edddf641cdf96d75c5fd44a2d3adfe40320f47..1b4606d43e24e15b97b288473cd57e5c78a33ba1 100644 (file)
@@ -7,7 +7,7 @@ LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat"
 
 DEPENDS = "${PROTO_DEPS}  ${LIB_DEPS} mesa-dri-glsl-native"
 
-PR = "r2"
+PR = "r3"
 
 SRC_URI += "file://crossfix.patch"
 
@@ -20,9 +20,6 @@ SRC_URI[mesademos.sha256sum] = "ea7b9ebfb7a80de2b275c0c9124c8a505382ec48411a2794
 # most of our targets do not have DRI so will use mesa-xlib
 DEFAULT_PREFERENCE = "-1"
 
-# Atom PCs have DRI support so use mesa-dri by default
-DEFAULT_PREFERENCE_atom-pc = "1"
-
 LEAD_SONAME = "libGL.so.1"
 
 EXTRA_OECONF += "--with-driver=dri --disable-egl --disable-gallium"