]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3: remove patch that inadvertently disables xattrs
authorRoss Burton <ross.burton@intel.com>
Mon, 10 Sep 2018 13:31:22 +0000 (14:31 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 11 Sep 2018 11:09:11 +0000 (12:09 +0100)
This patch dates back to the addition of the Python 3 recipe to oe-core, and as
listxattr is never added to supports_follow_symlinks the extended attribute
support will never be enabled.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python3-native_3.5.5.bb
meta/recipes-devtools/python/python3/shutil-follow-symlink-fix.patch [deleted file]
meta/recipes-devtools/python/python3_3.5.5.bb

index 7b940a16d282731b33b43e3f65fb0749460387f8..b231542f46f2649bede22e36b63d3ee4bfa8183c 100644 (file)
@@ -15,7 +15,6 @@ file://150-fix-setupterm.patch \
 file://python-3.3-multilib.patch \
 file://03-fix-tkinter-detection.patch \
 file://avoid_warning_about_tkinter.patch \
-file://shutil-follow-symlink-fix.patch \
 file://0001-h2py-Fix-issue-13032-where-it-fails-with-UnicodeDeco.patch \
 file://sysroot-include-headers.patch \
 file://unixccompiler.patch \
diff --git a/meta/recipes-devtools/python/python3/shutil-follow-symlink-fix.patch b/meta/recipes-devtools/python/python3/shutil-follow-symlink-fix.patch
deleted file mode 100644 (file)
index 802b1c7..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-shutils should consider symlinks
-
--Khem
-
-Upstream-Status: Pending
-
---- a/Lib/shutil.py    2013-01-29 12:31:06.926555779 -0800
-+++ b/Lib/shutil.py    2013-01-29 16:31:39.097554182 -0800
-@@ -132,7 +132,7 @@ def copymode(src, dst, *, follow_symlink
-     st = stat_func(src)
-     chmod_func(dst, stat.S_IMODE(st.st_mode))
--if hasattr(os, 'listxattr'):
-+if hasattr(os, 'listxattr') and os.listxattr in os.supports_follow_symlinks:
-     def _copyxattr(src, dst, *, follow_symlinks=True):
-         """Copy extended filesystem attributes from `src` to `dst`.
index 6598b486afeda5b8a428ddb538891fa17f1ba139..02decf470c8be03a8e156f762f299b37bfa2839f 100644 (file)
@@ -28,7 +28,6 @@ SRC_URI += "\
             file://cgi_py.patch \
             file://host_include_contamination.patch \
             file://python-3.3-multilib.patch \
-            file://shutil-follow-symlink-fix.patch \
             file://sysroot-include-headers.patch \
             file://unixccompiler.patch \
             file://avoid-ncursesw-include-path.patch \