]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3: remove redundant assignments
authorRoss Burton <ross.burton@intel.com>
Tue, 11 Sep 2018 15:22:13 +0000 (16:22 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 12 Sep 2018 23:27:55 +0000 (00:27 +0100)
_PYTHON_PROJECT_BASE and _PYTHON_PROJECT_SRC appear to be set in setup.py from
the source directory and build directory correctly, so this is redundant.

Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/python/python3_3.5.6.bb

index c2af5e9b4867cd80f29b65d1cf4768fbfd1ce56e..d341b2773ea74ba5141e7d46ad311c2b011f70a0 100644 (file)
@@ -72,8 +72,6 @@ EXTRA_OECONF += "CROSSPYTHONPATH=${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}
 PYTHON3_PROFILE_TASK ?= "./python -m test.regrtest --pgo test_grammar test_opcodes test_dict test_builtin test_exceptions test_types test_support || true"
 
 export CROSS_COMPILE = "${TARGET_PREFIX}"
-export _PYTHON_PROJECT_BASE = "${B}"
-export _PYTHON_PROJECT_SRC = "${S}"
 export CCSHARED = "-fPIC"
 
 # Fix cross compilation of different modules