]> code.ossystems Code Review - openembedded-core.git/commitdiff
libgalego: Add patch for mkinstalldirs problems
authorRichard Purdie <rpurdie@linux.intel.com>
Wed, 19 Aug 2009 20:04:49 +0000 (21:04 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 19 Aug 2009 20:04:49 +0000 (21:04 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/galago/libgalago-0.5.2/mkdir.patch [new file with mode: 0644]
meta/packages/galago/libgalago_0.5.2.bb

diff --git a/meta/packages/galago/libgalago-0.5.2/mkdir.patch b/meta/packages/galago/libgalago-0.5.2/mkdir.patch
new file mode 100644 (file)
index 0000000..f893bff
--- /dev/null
@@ -0,0 +1,27 @@
+Index: libgalago-0.5.2/po/Makefile.in.in
+===================================================================
+--- libgalago-0.5.2.orig/po/Makefile.in.in     2006-06-06 09:59:17.000000000 +0100
++++ libgalago-0.5.2/po/Makefile.in.in  2009-08-19 20:31:56.000000000 +0100
+@@ -29,7 +29,7 @@
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+ MKINSTALLDIRS = @MKINSTALLDIRS@
+-mkinstalldirs = $(SHELL) `case "$(MKINSTALLDIRS)" in /*) echo "$(MKINSTALLDIRS)" ;; *) echo "$(MKINSTALLDIRS)" ;; esac`
++mkinstalldirs = $(MKINSTALLDIRS)
+ CC = @CC@
+ GMSGFMT = @GMSGFMT@
+Index: libgalago-0.5.2/configure.ac
+===================================================================
+--- libgalago-0.5.2.orig/configure.ac  2009-08-19 20:30:56.000000000 +0100
++++ libgalago-0.5.2/configure.ac       2009-08-19 20:31:28.000000000 +0100
+@@ -157,6 +157,9 @@
+ AC_SUBST(CFLAGS)
++MKINSTALLDIRS="mkdir -p"
++AC_SUBST(MKINSTALLDIRS)
++
+ dnl ################################################################
+ dnl # Output the Makefiles
+ dnl ################################################################
index d4dd3aaba3deca60bd73504433c5d4fe9cdc7455..ee485905db517fe9575b93585a5ef36fee6b0485 100644 (file)
@@ -4,8 +4,9 @@ LICENSE =       "LGPL"
 DEPENDS =      "gettext dbus glib-2.0 dbus-glib"
 
 SRC_URI =      "http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.gz \
+                 file://mkdir.patch;patch=1 \
                  file://pkgconfig.patch;patch=1 "
-PR = "r1"
+PR = "r2"
 
 inherit autotools_stage pkgconfig