]> code.ossystems Code Review - openembedded-core.git/commitdiff
libcap: only enable pam if DISTRO_FEATURES requests it
authorPhil Blundell <philb@gnu.org>
Tue, 30 Aug 2011 16:27:13 +0000 (17:27 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 31 Aug 2011 18:58:51 +0000 (19:58 +0100)
Signed-off-by: Phil Blundell <philb@gnu.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/libcap/libcap.inc
meta/recipes-support/libcap/libcap_2.22.bb

index 67f7579e1d4f13b5855e03b235808d27b4cca3a2..350653071eab8ff9b7752702b8289ea134612559 100644 (file)
@@ -5,7 +5,8 @@ HOMEPAGE = "http://sites.google.com/site/fullycapable/"
 LICENSE = "BSD | GPLv2"
 LIC_FILES_CHKSUM = "file://License;md5=3f84fd6f29d453a56514cb7e4ead25f1"
 
-DEPENDS = "libpam attr perl-native-runtime"
+DEPENDS = "attr perl-native-runtime"
+DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
 # attr and pam are disabled by EXTRA_OEMAKE_virtclass-native
 DEPENDS_virtclass-native = "perl-native-runtime"
 
@@ -20,7 +21,7 @@ do_configure() {
        sed -e 's,BUILD_CFLAGS ?=,BUILD_CFLAGS := $(BUILD_CFLAGS),' -i Make.Rules
 }
 
-EXTRA_OEMAKE = "LIBATTR=yes PAM_CAP=yes INDENT= SYSTEM_HEADERS=${STAGING_INCDIR} RAISE_SETFCAP=no"
+EXTRA_OEMAKE = "LIBATTR=yes PAM_CAP=${@base_contains('DISTRO_FEATURES', 'pam', 'yes', 'no', d)} INDENT= SYSTEM_HEADERS=${STAGING_INCDIR} RAISE_SETFCAP=no"
 EXTRA_OEMAKE_virtclass-native = "LIBATTR=no PAM_CAP=no INDENT= "
 EXTRA_OEMAKE += " lib=${@os.path.basename('${libdir}')}"
 
index bb49c031c61572023fe5021e49674b20e5aee219..a31ba3fadd905f534684cf049f3bda5032742c02 100644 (file)
@@ -1,6 +1,6 @@
 require libcap.inc
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI[md5sum] = "ce64058bdb3f086ddbfca8ce6c919845"
 SRC_URI[sha256sum] = "73ebbd4877b5f69dd28b72098e510c5b318bc480f8201c4061ac98b78c04050f"