]> code.ossystems Code Review - openembedded-core.git/commitdiff
file: Update to 5.34
authorKhem Raj <raj.khem@gmail.com>
Mon, 6 Aug 2018 22:57:09 +0000 (15:57 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 8 Aug 2018 09:51:28 +0000 (10:51 +0100)
Distros which have glibc 2.28 on them otherwsise fail
to build due to some syscall mismatches

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/file/file/CVE-2018-10360.patch [deleted file]
meta/recipes-devtools/file/file/fix-bogus-magic.patch [deleted file]
meta/recipes-devtools/file/file_5.34.bb [moved from meta/recipes-devtools/file/file_5.33.bb with 91% similarity]

diff --git a/meta/recipes-devtools/file/file/CVE-2018-10360.patch b/meta/recipes-devtools/file/file/CVE-2018-10360.patch
deleted file mode 100644 (file)
index 7f5671b..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-From df494f4ca494b5e1044052d96a6092a16ef1f6b3 Mon Sep 17 00:00:00 2001
-From: Christos Zoulas <christos@zoulas.com>
-Date: Sat, 9 Jun 2018 16:00:06 +0000
-Subject: [PATCH] Avoid reading past the end of buffer (Rui Reis)
-
-Upstream-Status: Backport
-[https://github.com/file/file/commit/a642587a9c9e2dd7feacdf513c3643ce26ad3c22]
-
-CVE: CVE-2018-10360
-
-Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
----
- src/readelf.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/src/readelf.c b/src/readelf.c
-index 3df0836..d96a538 100644
---- a/src/readelf.c
-+++ b/src/readelf.c
-@@ -825,7 +825,8 @@ do_core_note(struct magic_set *ms, unsigned char *nbuf, uint32_t type,
-                               cname = (unsigned char *)
-                                   &nbuf[doff + prpsoffsets(i)];
--                              for (cp = cname; *cp && isprint(*cp); cp++)
-+                              for (cp = cname; cp < nbuf + size && *cp
-+                                  && isprint(*cp); cp++)
-                                       continue;
-                               /*
-                                * Linux apparently appends a space at the end
--- 
-2.7.4
-
diff --git a/meta/recipes-devtools/file/file/fix-bogus-magic.patch b/meta/recipes-devtools/file/file/fix-bogus-magic.patch
deleted file mode 100644 (file)
index 9a33ea7..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-From c637aaad6f0db5ad45a5296c837cb1f5253d3e3a Mon Sep 17 00:00:00 2001
-From: Christos Zoulas <christos@zoulas.com>
-Date: Thu, 24 May 2018 18:54:40 +0000
-Subject: [PATCH] fix bogus magic
-
-Upstream-Status: Backport
-[https://github.com/file/file/commit/4fb6a59df80d4974f8230bfce36e38e6de7d574f]
-
-Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
----
- magic/Magdir/dbpf | 6 ++----
- 1 file changed, 2 insertions(+), 4 deletions(-)
-
-diff --git a/magic/Magdir/dbpf b/magic/Magdir/dbpf
-index 65cab61e..e81c5538 100644
---- a/magic/Magdir/dbpf
-+++ b/magic/Magdir/dbpf
-@@ -9,9 +9,7 @@
- >4    ulelong x       \b, version: %u.
- >>8   ulelong x       \b%u
- >>>36 ulelong x       \b, files: %u
-+>>24  ledate  !0      \b, created: %s
-+>>28  ledate  !0      \b, modified: %s
- !:ext dbpf/package/dat/sc4
- !:mime        application/x-maxis-dbpf
--4     ulelong 1
-->8    ulelong !1
-->>24  ledate  !0      \b, created: %s
-->>>28 ledate  !0      \b, modified: %s
--- 
-2.13.3
-
similarity index 91%
rename from meta/recipes-devtools/file/file_5.33.bb
rename to meta/recipes-devtools/file/file_5.34.bb
index a29402a0abbd56119b212f66cbdc905ff075612f..6612b71000e3e11c35a6c05c3a5fabf8eb12c1a6 100644 (file)
@@ -16,11 +16,9 @@ UPSTREAM_CHECK_GITTAGREGEX = "FILE(?P<pver>(?!6_23).+)"
 
 SRC_URI = "git://github.com/file/file.git \
         file://debian-742262.patch \
-        file://CVE-2018-10360.patch \
-        file://fix-bogus-magic.patch \
         "
 
-SRCREV = "219846094c7593e27453e62855e61181089c48cf"
+SRCREV = "315cef2f699da3c31a54bd3c6c6070680fbaf1f5"
 S = "${WORKDIR}/git"
 
 inherit autotools