]> code.ossystems Code Review - openembedded-core.git/commitdiff
sysvinit-inittab: Disable the carrier detect requirement for serial consoles
authorOtavio Salvador <otavio@ossystems.com.br>
Wed, 12 Nov 2014 10:33:25 +0000 (08:33 -0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 6 Jan 2015 14:13:04 +0000 (14:13 +0000)
This aligns the params of getty with the ones used in Debian. From the
getty(8) manpage:

,----[ getty(8) manpage ]
|  -L, --local-line
|
|    Force the line to be a local line with no need for carrier
|   detect. This can be useful when you have a locally attached
|   terminal where the serial line does not set the carrier detect
|   signal.
`----

Reported-by: Craig McQueen <craig.mcqueen@beamcommunications.com>
(From OE-Core rev: a899c362be71cb7b94bd318c57702446b017005c)

Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Tested-by: Craig McQueen <craig.mcqueen@beamcommunications.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb

index c3244b46021e06be6d9860996e6e764b3b026d5e..657ef022048f505e4478a797530f0ff8df22ce04 100644 (file)
@@ -23,7 +23,7 @@ do_install() {
     do
        j=`echo ${i} | sed s/\;/\ /g`
        label=`echo ${i} | sed -e 's/^.*;tty//' -e 's/;.*//'`
-       echo "$label:12345:respawn:${base_sbindir}/getty ${j}" >> ${D}${sysconfdir}/inittab
+       echo "$label:12345:respawn:${base_sbindir}/getty -L ${j}" >> ${D}${sysconfdir}/inittab
     done
 
     if [ "${USE_VT}" = "1" ]; then