]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: Ensure we general PIC code to avoid build failures
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 27 Aug 2013 11:30:34 +0000 (11:30 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 27 Aug 2013 11:31:55 +0000 (12:31 +0100)
Without this we see relocation errors on mips with 3.10. This should be
safe to be included in general.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/perf/perf.bb

index 844e8807caa71d123ad28abe43e11ed9008d09a9..a78fc057bb461754c32b1d65618c054767c81f2f 100644 (file)
@@ -73,7 +73,7 @@ EXTRA_OEMAKE = \
 # don't override it, it'll add -m32/-m64 itself). For LDFLAGS, it was failing
 # to find bfd symbols.
 EXTRA_OEMAKE += "\
-       'CFLAGS=${CFLAGS}' \
+       'CFLAGS=${CFLAGS} -fPIC' \
        'LDFLAGS=${LDFLAGS} -lpthread -lrt -lelf -lm -lbfd' \
        \
        'prefix=${prefix}' \