]> code.ossystems Code Review - openembedded-core.git/commitdiff
lsbtest: fix comparison bashism
authorStefan Stanacar <stefanx.stanacar@intel.com>
Wed, 12 Mar 2014 18:59:28 +0000 (18:59 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 13 Mar 2014 22:38:02 +0000 (15:38 -0700)
== is a bashism use = instead.

(Based on OE-Core master rev: c90d1047c41148cbd57f26b5a34563346602a71b)

Signed-off-by: Stefan Stanacar <stefanx.stanacar@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/lsb/lsbtest/LSB_Test.sh
meta/recipes-extended/lsb/lsbtest_1.0.bb

index af1d61c0ce63fb5025f7f5c36d20cd324a6956e8..cea01990e16419ff627215fb453c9dc9ef3c9d7e 100644 (file)
@@ -272,7 +272,7 @@ then
 fi
 
 if ! `grep -F -q "noarch-suse" ${PLATFORM_FILE}`; then
-       if [ ${ARCH} == i686 ];then
+       if [ ${ARCH} = i686 ];then
                echo "i486-suse" >> ${PLATFORM_FILE}
                echo "i486-noarch" >> ${PLATFORM_FILE}
                echo "i486-pc" >> ${PLATFORM_FILE}
index 8973e094e5739d1e1e8e7dcb163f30b9bad7adbc..84cb4f2425ff3873412e2f7c9f82e4a4945c8dc4 100644 (file)
@@ -19,15 +19,15 @@ do_install() {
        install -d  ${D}/opt/lsb-test
        install -m 0644 ${S}/packages_list ${D}/opt/lsb-test/packages_list
        install -m 0644 ${S}/session ${D}/opt/lsb-test/session
-       if [ "${TARGET_ARCH}" == "i586" ];then
+       if [ "${TARGET_ARCH}" = "i586" ];then
                sed -i -e 's/lsbarch/ia32/g' -e 's/targetarch/i486/g' ${D}/opt/lsb-test/packages_list
                sed -i -e 's/targetarch/x86/g' ${D}/opt/lsb-test/session
        fi
-       if [ "${TARGET_ARCH}" == "x86_64" ];then
+       if [ "${TARGET_ARCH}" = "x86_64" ];then
                sed -i -e 's/lsbarch/amd64/g' -e 's/targetarch/x86_64/g' ${D}/opt/lsb-test/packages_list
                sed -i -e 's/targetarch/x86-64/g' ${D}/opt/lsb-test/session
        fi
-       if [ "${TARGET_ARCH}" == "powerpc" ];then
+       if [ "${TARGET_ARCH}" = "powerpc" ];then
                sed -i -e 's/lsbarch/ppc32/g' -e 's/targetarch/ppc/g' ${D}/opt/lsb-test/packages_list
                sed -i -e 's/targetarch/PPC32/g' ${D}/opt/lsb-test/session
        fi