]> code.ossystems Code Review - openembedded-core.git/commitdiff
boost: Activate zlib and bzip2 because they now work.
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>
Sat, 20 Oct 2012 15:50:13 +0000 (17:50 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 13 Nov 2012 14:09:50 +0000 (14:09 +0000)
This patch is needed for making wesnoth(will be sumbited
  in meta-games) work.

[RP: Add missing bzip2 dependency]
Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/boost/boost.inc

index 36a94e10ea0b0669345878725b0f3a2a769fb836..830fcb0568297ef40886ee647b5a2b5f5a074622 100644 (file)
@@ -6,7 +6,7 @@
 DESCRIPTION = "Free peer-reviewed portable C++ source libraries"
 HOMEPAGE = "http://www.boost.org/"
 SECTION = "libs"
-DEPENDS = "boost-native zlib"
+DEPENDS = "boost-native zlib bzip2"
 DEPENDS_class-native = ""
 LICENSE = "BSL-1.0 & MIT & Python-2.0"
 
@@ -16,7 +16,7 @@ BOOST_VER = "${@"_".join(d.getVar("PV",1).split("."))}"
 BOOST_MAJ = "${@"_".join(d.getVar("PV",1).split(".")[0:2])}"
 BOOST_P = "boost_${BOOST_VER}"
 
-INC_PR = "r4"
+INC_PR = "r5"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BOOST_P}.tar.bz2"
 
@@ -109,16 +109,11 @@ EQD = '\"'
 #boost.bb:   "...  '-sGCC=... '${SQD}'-DBOOST_PLATFORM_CONFIG=${EQD}config${EQD}'${SQD} ..."
 BJAM_CONF = "${SQD}'-DBOOST_PLATFORM_CONFIG=${EQD}boost/config/platform/${TARGET_OS}.hpp${EQD}'${SQD}"
 
-# bzip2 and zip are disabled because... they're broken - the compilation simply
-# isn't working with bjam.  I guess they will fix it, but who needs it?  This
-# only affects the (new in 33) iostream library.
 BJAM_TOOLS   = "-sTOOLS=gcc \
                '-sGCC=${CC} '${BJAM_CONF} \
                '-sGXX=${CXX} '${BJAM_CONF} \
                '-sGCC_INCLUDE_DIRECTORY=${STAGING_INCDIR}' \
                '-sGCC_STDLIB_DIRECTORY=${STAGING_LIBDIR}' \
-               '-sNO_BZIP2=1' \
-               '-sNO_ZLIB=1' \
                '-sBUILD=release <optimization>space <threading>multi <inlining>on <debug-symbols>off' \
                '-sPYTHON_VERSION=${PYTHON_VERSION}' \
                '-sPYTHON_ROOT=${PYTHON_ROOT}' \