]> code.ossystems Code Review - openembedded-core.git/commitdiff
binutils-cross 2.18: unbreak x86-64 hosts - from OE #2928-c6
authorMarcin Juszkiewicz <hrw@openedhand.com>
Tue, 11 Sep 2007 11:18:41 +0000 (11:18 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Tue, 11 Sep 2007 11:18:41 +0000 (11:18 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2723 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/binutils/binutils-cross_2.18.bb

index a418dfaab57f9287ecaa7e4964f65ca9afcfa334..f51badecf72353427813d10e3d5b62e18f58c29e 100644 (file)
@@ -1,3 +1,25 @@
 require binutils_${PV}.bb
 require binutils-cross.inc
+PR = "r1"
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/binutils-${PV}"
+
+do_stage () {
+       oe_runmake install
+
+       MULTILIBDIR=`gcc -print-multi-os-directory`
+
+       # We don't really need these, so we'll remove them...
+       rm -rf ${CROSS_DIR}/lib/ldscripts
+       rm -rf ${CROSS_DIR}/share/info
+       rm -rf ${CROSS_DIR}/share/locale
+       rm -rf ${CROSS_DIR}/share/man
+       rmdir ${CROSS_DIR}/share || :
+       rmdir ${CROSS_DIR}/${libdir}/gcc-lib || :
+       rmdir ${CROSS_DIR}/${libdir} || :
+       rmdir ${CROSS_DIR}/${prefix} || :
+
+       # We want to move this into the target specific location
+       mkdir -p ${CROSS_DIR}/${TARGET_SYS}/lib
+       mv -f ${CROSS_DIR}/lib/${MULTILIBDIR}/libiberty.a ${CROSS_DIR}/${TARGET_SYS}/lib
+       rmdir ${CROSS_DIR}/lib/${MULTILIBDIR} || :
+}