]> code.ossystems Code Review - openembedded-core.git/commitdiff
packagegroup-core-standalone-sdk-target: Add libgcov-dev to on device SDK
authorNobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>
Tue, 16 Sep 2014 01:01:01 +0000 (10:01 +0900)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 29 Sep 2014 11:11:48 +0000 (12:11 +0100)
When a user takes coverage in gcc of SDK, it becomes the link error in SDK
because there is not libgcov.

----
ld: cannot find -lgcov
collect2: error: ld returned 1 exit status
----

Signed-off-by: Nobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/packagegroups/packagegroup-core-standalone-sdk-target.bb

index 5d1ce97c2c91cc65c4a1234d5d86c59bbdb3bb4a..154a55cea20e74df33e042d32790ea260891fb97 100644 (file)
@@ -7,6 +7,7 @@ inherit packagegroup
 RDEPENDS_${PN} = "\
     libgcc \
     libgcc-dev \
+    libgcov-dev \
     libstdc++ \
     libstdc++-dev \
     ${LIBC_DEPENDENCIES} \