]> code.ossystems Code Review - openembedded-core.git/commitdiff
git: fix sstate relocation for git-native
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Mon, 5 Sep 2011 15:37:04 +0000 (16:37 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 5 Sep 2011 19:19:50 +0000 (20:19 +0100)
Create a wrapper for git to set GIT_EXEC_PATH and GIT_TEMPLATE_DIR so
that git-native is relocatable.

Fixes specific example given in [YOCTO #1137]

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
meta/recipes-devtools/git/git.inc
meta/recipes-devtools/git/git_1.7.5.1.bb

index 56655f93be90937856ce02eca7834ad6e08e3169..ca13ffd704d24549e8d82228ffab31bb50af22ec 100644 (file)
@@ -18,6 +18,12 @@ do_install () {
                GIT_PYTHON_DIR=${D}${datadir}/git-core/python
 }
 
+do_install_append_virtclass-native() {
+       create_wrapper ${D}/${bindir}/git \
+               GIT_EXEC_PATH=${libexecdir}/git-core \
+               GIT_TEMPLATE_DIR=${STAGING_DATADIR_NATIVE}/git-core/templates
+}
+
 FILES_${PN} += "${datadir}/git-core ${libxecdir}/git-core/"
 FILES_${PN}-dbg += "${libexecdir}/git-core/.debug"
 
index 04d1d5602cd1f41422a805eb6bd17faed7f444ba..b5eb01511bf11dd12d5665f5f055a8d4a088b6cc 100644 (file)
@@ -1,6 +1,6 @@
 require git.inc
 
-PR = "r2"
+PR = "r3"
 
 EXTRA_OECONF += "ac_cv_snprintf_returns_bogus=no ac_cv_c_c99_format=yes \
                  ac_cv_fread_reads_directories=${ac_cv_fread_reads_directories=yes} \