]> code.ossystems Code Review - openembedded-core.git/commitdiff
gawk: Add missing dependency on readline
authorKhem Raj <raj.khem@gmail.com>
Thu, 24 Jan 2013 20:18:23 +0000 (12:18 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 25 Jan 2013 14:37:13 +0000 (14:37 +0000)
building from shared state often ends up with

|
/b/kraj/angstrom/build/tmp-angstrom_next-uclibc/work/i586-angstrom-linux-uclibc/gawk/4.0.1-r1/gawk-4
.0.1/debug.c:4135: undefined reference to `rl_reset_terminal'
|
/b/kraj/angstrom/build/tmp-angstrom_next-uclibc/work/i586-angstrom-linux-uclibc/gawk/4.0.1-r1/gawk-4
.0.1/debug.c:4138: undefined reference to `rl_get_screen_size'
| debug.o: In function `unserialize':

Adding the missing readline dependency to fix such cases
where readline has not been populated in sysroot via some
other dependency and gawk would then use it or bail out.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
meta/recipes-extended/gawk/gawk_4.0.1.bb

index fcd761984d8e7d8080c1746792ff758f326604a2..38ad25b588d1c905184088230d203463d9567e61 100644 (file)
@@ -9,6 +9,8 @@ SECTION = "console/utils"
 LICENSE = "GPLv3"
 LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
 
+DEPENDS += "readline"
+
 RDEPENDS_gawk += "gawk-common"
 RDEPENDS_pgawk += "gawk-common"
 PR = "r1"