]> code.ossystems Code Review - openembedded-core.git/commitdiff
gmp: refresh patches
authorRoss Burton <ross.burton@intel.com>
Thu, 8 Mar 2018 18:17:29 +0000 (20:17 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 9 Mar 2018 17:15:59 +0000 (09:15 -0800)
The patch tool will apply patches by default with "fuzz", which is where if the
hunk context isn't present but what is there is close enough, it will force the
patch in.

Whilst this is useful when there's just whitespace changes, when applied to
source it is possible for a patch applied with fuzz to produce broken code which
still compiles (see #10450).  This is obviously bad.

We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For
that to be realistic the existing patches with fuzz need to be rebased and
reviewed.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-support/gmp/gmp-6.1.2/0001-confiure.ac-Believe-the-cflags-from-environment.patch
meta/recipes-support/gmp/gmp-6.1.2/amd64.patch
meta/recipes-support/gmp/gmp-6.1.2/use-includedir.patch

index 665367658bc6c8597a09abc8197316cb9c77bf08..1e47924ccc701d5c9024431091cd6f987dd255b2 100644 (file)
@@ -18,13 +18,13 @@ Upstream-Status: Inappropriate[OE-Specific]
  configure.ac | 11 -----------
  1 file changed, 11 deletions(-)
 
-diff --git a/configure.ac b/configure.ac
-index 857ea3b..359e919 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -607,15 +607,6 @@ case $host in
-     GMP_INCLUDE_MPN(arm/arm-defs.m4)
-     CALLING_CONVENTIONS_OBJS='arm32call.lo arm32check.lo'
+Index: gmp-6.1.2/configure.ac
+===================================================================
+--- gmp-6.1.2.orig/configure.ac
++++ gmp-6.1.2/configure.ac
+@@ -604,15 +604,6 @@ case $host in
+     any_32_testlist="sizeof-long-4"
+     any_64_testlist="sizeof-long-8"
  
 -    # This is needed for clang, which is not content with flags like -mfpu=neon
 -    # alone.
@@ -38,7 +38,7 @@ index 857ea3b..359e919 100644
      # FIXME: We make mandatory compiler options optional here.  We should
      # either enforce them, or organise to strip paths as the corresponding
      # options fail.
-@@ -686,8 +677,6 @@ case $host in
+@@ -746,8 +737,6 @@ case $host in
        ;;
        *)
        path="arm"
@@ -47,6 +47,3 @@ index 857ea3b..359e919 100644
        ;;
      esac
      ;;
--- 
-1.9.1
-
index 564d12d42b9dc2245110cb1268ad6e4cc84cab43..3935589f8b22ca1d69b8de7ecd1f74eb7c6977b2 100644 (file)
@@ -1,10 +1,10 @@
 Upstream-Status: Pending
 
-Index: gmp-5.0.3/longlong.h
+Index: gmp-6.1.2/longlong.h
 ===================================================================
---- gmp-5.0.3.orig/longlong.h
-+++ gmp-5.0.3/longlong.h
-@@ -994,8 +994,10 @@ extern UWtype __MPN(udiv_qrnnd) _PROTO (
+--- gmp-6.1.2.orig/longlong.h
++++ gmp-6.1.2/longlong.h
+@@ -1036,8 +1036,10 @@ extern UWtype __MPN(udiv_qrnnd) (UWtype
     count is only an int. */
  #define count_trailing_zeros(count, x)                                        \
    do {                                                                        \
@@ -14,5 +14,5 @@ Index: gmp-5.0.3/longlong.h
 +    __asm__ ("bsfq %1,%0" : "=r" (__cbtmp) : "rm" ((UDItype)(x)));    \
 +    (count) = __cbtmp;                                                        \
    } while (0)
- #endif /* x86_64 */
+ #endif /* __amd64__ */
  
index 74904a25302dca990941a2cd9cb52beac720a8e0..6b089cf39c27689ba9c9876eeb6d2db8beed2845 100644 (file)
@@ -1,15 +1,15 @@
 Upstream-Status: Pending
 
-Index: gmp-4.2.4/Makefile.am
+Index: gmp-6.1.2/Makefile.am
 ===================================================================
---- gmp-4.2.4.orig/Makefile.am 2008-09-10 19:31:27.000000000 +0000
-+++ gmp-4.2.4/Makefile.am      2009-07-06 20:19:19.000000000 +0000
-@@ -106,7 +106,7 @@
- # but anyone knowledgable enough to be playing with exec_prefix will be able
+--- gmp-6.1.2.orig/Makefile.am
++++ gmp-6.1.2/Makefile.am
+@@ -130,7 +130,7 @@ EXTRA_DIST += gmpxx.h
+ # but anyone knowledgeable enough to be playing with exec_prefix will be able
  # to address that.
  #
 -includeexecdir = $(exec_prefix)/include
 +includeexecdir = $(includedir)
  include_HEADERS = $(GMPXX_HEADERS_OPTION)
- nodist_includeexec_HEADERS = gmp.h $(MPBSD_HEADERS_OPTION)
- lib_LTLIBRARIES = libgmp.la $(GMPXX_LTLIBRARIES_OPTION) $(MPBSD_LTLIBRARIES_OPTION)
+ nodist_includeexec_HEADERS = gmp.h
+ lib_LTLIBRARIES = libgmp.la $(GMPXX_LTLIBRARIES_OPTION)