]> code.ossystems Code Review - openembedded-core.git/commitdiff
kernel-devsrc: fix 32bit ARM devsrc builds 2020-04.10 2020-04.10-dunfell yocto-3.1.10
authorBruce Ashfield <bruce.ashfield@gmail.com>
Sat, 26 Dec 2020 21:50:02 +0000 (16:50 -0500)
committerSteve Sakoman <steve@sakoman.com>
Tue, 20 Jul 2021 16:36:58 +0000 (06:36 -1000)
As a follow up to commit: 0fc66a0b64953 [kernel: provide module.lds
for out of tree builds in v5.10+], we must not only copy module.lds
from its new location, we have to not error when it isn't found in
the old location.

With this tweak, we have coverage on all supported arches for the
new location of module.lds, and backwards compatibility through
kernel versions.

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit cb940d8af359fa370254bd4c2b36ba26708bb54b)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-kernel/linux/kernel-devsrc.bb

index 951e7635cc6b310b6a7ff4d984da9bca36cb36f7..887e1e2430025c9c90d2383b68220ac16bb0395f 100644 (file)
@@ -177,7 +177,7 @@ do_install() {
                cp -a --parents $SYSCALL_TOOLS $kerneldir/build/
             fi
 
-            cp -a --parents arch/arm/kernel/module.lds $kerneldir/build/
+            cp -a --parents arch/arm/kernel/module.lds $kerneldir/build/ 2>/dev/null || :
        fi
 
        if [ -d arch/${ARCH}/include ]; then