]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3: add readline to PACKAGECONFIG
authorAnuj Mittal <anuj.mittal@intel.com>
Thu, 15 Mar 2018 05:38:56 +0000 (13:38 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 19 Mar 2018 23:05:01 +0000 (23:05 +0000)
Provide a way to make readline dependency optional in case someone
might want to use BSD alternative editline instead.

Using editline would need some changes though (python issue13501).

Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/python/python3_3.5.5.bb

index 8150dd6997ed929520f4a67f189faa89a7f4f2e4..d458d32e60d0e40c6ad4280a7dedb04759e99ea2 100644 (file)
@@ -1,6 +1,6 @@
 require recipes-devtools/python/python.inc
 
-DEPENDS = "python3-native libffi bzip2 gdbm openssl readline sqlite3 zlib virtual/libintl xz"
+DEPENDS = "python3-native libffi bzip2 gdbm openssl sqlite3 zlib virtual/libintl xz"
 
 PR = "${INC_PR}.0"
 PYTHON_MAJMIN = "3.5"
@@ -76,6 +76,9 @@ export CROSSPYTHONPATH = "${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dy
 # No ctypes option for python 3
 PYTHONLSBOPTS = ""
 
+PACKAGECONFIG ??= "readline"
+PACKAGECONFIG[readline] = ",,readline"
+
 do_configure_append() {
        rm -f ${S}/Makefile.orig
        autoreconf -Wcross --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi