]> code.ossystems Code Review - openembedded-core.git/commitdiff
cve-update-db-native: add more logging when fetching
authorRoss Burton <ross@burtonini.com>
Thu, 10 Sep 2020 21:04:12 +0000 (22:04 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 11 Sep 2020 17:05:02 +0000 (18:05 +0100)
Add some debug logging when fetching the CVE data.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/meta/cve-update-db-native.bb

index 94367f9a94ddd2eb4a22ae892fe2b8bd850e1118..27b4c58d4ebf461b9a2bfb159d84d8d232ba16bc 100644 (file)
@@ -46,6 +46,7 @@ python do_populate_cve_db() {
     try:
         import time
         if time.time() - os.path.getmtime(db_file) < (60*60):
+            bb.debug(2, "Recently updated, skipping")
             return
     except OSError:
         pass
@@ -61,6 +62,7 @@ python do_populate_cve_db() {
     with bb.progress.ProgressHandler(d) as ph, open(os.path.join(d.getVar("TMPDIR"), 'cve_check'), 'a') as cve_f:
         total_years = date.today().year + 1 - YEAR_START
         for i, year in enumerate(range(YEAR_START, date.today().year + 1)):
+            bb.debug(2, "Updating %d" % year)
             ph.update((float(i + 1) / total_years) * 100)
             year_url = BASE_URL + str(year)
             meta_url = year_url + ".meta"
@@ -88,6 +90,7 @@ python do_populate_cve_db() {
             c.execute("select DATE from META where YEAR = ?", (year,))
             meta = c.fetchone()
             if not meta or meta[0] != last_modified:
+                bb.debug(2, "Updating entries")
                 # Clear products table entries corresponding to current year
                 c.execute("delete from PRODUCTS where ID like ?", ('CVE-%d%%' % year,))
 
@@ -101,7 +104,8 @@ python do_populate_cve_db() {
                     cve_f.write('Warning: CVE db update error, CVE data is outdated.\n\n')
                     bb.warn("Cannot parse CVE data (%s), update failed" % e.reason)
                     return
-
+            else:
+                bb.debug(2, "Already up to date (last modified %s)" % last_modified)
             # Update success, set the date to cve_check file.
             if year == date.today().year:
                 cve_f.write('CVE database update : %s\n\n' % date.today())