]> code.ossystems Code Review - openembedded-core.git/commitdiff
openssh: move setting LD to allow for correct override
authorSaul Wold <sgw@linux.intel.com>
Mon, 15 Dec 2014 19:21:49 +0000 (11:21 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 19 Dec 2014 17:54:12 +0000 (17:54 +0000)
Using the export LD in the recipe does not allow for secodnary toolchain
overriding LD later, by setting it in the do_configure_append the export
is used by autotools setting LD based on the env, but would allow for
override later.

[YOCTO #6997]

Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-connectivity/openssh/openssh_6.6p1.bb

index dbcf4146edcc7a7c17b3c816f2fa1574b92d2282..abc302b90fd4798d9a3f85af41542d53c459120e 100644 (file)
@@ -49,7 +49,6 @@ inherit autotools-brokensep ptest
 
 # LFS support:
 CFLAGS += "-D__FILE_OFFSET_BITS=64"
-export LD = "${CC}"
 
 # login path is hardcoded in sshd
 EXTRA_OECONF = "'LOGIN_PROGRAM=${base_bindir}/login' \
@@ -74,6 +73,7 @@ CACHED_CONFIGUREVARS += "ac_cv_path_PATH_PASSWD_PROG=${bindir}/passwd"
 EXTRA_OECONF_append_libc-uclibc=" --without-pam"
 
 do_configure_prepend () {
+       export LD="${CC}"
        install -m 0644 ${WORKDIR}/sshd_config ${B}/
        install -m 0644 ${WORKDIR}/ssh_config ${B}/
        if [ ! -e acinclude.m4 -a -e aclocal.m4 ]; then