]> code.ossystems Code Review - openembedded-core.git/commitdiff
initscripts: Remove mtab madness from checkroot.sh since it doesn't work with busybox...
authorRichard Purdie <richard@openedhand.com>
Fri, 9 May 2008 17:16:11 +0000 (17:16 +0000)
committerRichard Purdie <richard@openedhand.com>
Fri, 9 May 2008 17:16:11 +0000 (17:16 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4458 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/initscripts/initscripts-1.0/checkroot.sh
meta/packages/initscripts/initscripts_1.0.bb

index 8255038c328a9cd0521317500263f411c4792191..c96c7b88cb6372ba4f5d51e407776f5b21704717 100755 (executable)
@@ -152,14 +152,7 @@ fi
 mount -n -o remount,$rootmode /
 if test "$rootmode" = rw
 then
-       if test ! -L /etc/mtab
-       then
-               rm -f /etc/mtab~ /etc/nologin
-               : > /etc/mtab
-       fi
-       mount -f -o remount /
-       mount -f /proc
-       test "$devfs" && grep -q '^devfs /dev' /proc/mounts && mount -f "$devfs"
+       ln -sf /proc/mounts /dev/mtab
 fi
 
 : exit 0
index 7fab41858b46f4e8d46606860c7650cfd5b1bb0b..4433d1231831e1e45215cce802e3780f3c309404 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "required"
 DEPENDS = "makedevs"
 RDEPENDS = "makedevs"
 LICENSE = "GPL"
-PR = "r103"
+PR = "r104"
 
 SRC_URI = "file://functions \
            file://halt \