]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-pycurl: Fix building
authorJoshua Lock <josh@linux.intel.com>
Tue, 30 Mar 2010 14:24:25 +0000 (15:24 +0100)
committerJoshua Lock <josh@linux.intel.com>
Wed, 31 Mar 2010 13:50:50 +0000 (14:50 +0100)
Add python to DEPENDS and ensure the required environment variables are
available at build time.

Signed-off-by: Joshua Lock <josh@linux.intel.com>
meta/packages/python/python-pycurl_7.19.0.bb

index 84b01dc50f7480a729431ad0b09cb501f7333e1b..2b0bd88ce1365ea1860d39b3bda389a3cb368e06 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "libcurl Python Bindings"
 SECTION = "devel/python"
 PRIORITY = "optional"
 LICENSE = "LGPL"
-DEPENDS = "curl"
+DEPENDS = "curl python"
 SRCNAME = "pycurl"
 PR = "r0"
 
@@ -17,6 +17,8 @@ inherit distutils
 # need to export these variables for python-config to work
 export BUILD_SYS
 export HOST_SYS
+export STAGING_INCDIR
+export STAGING_LIBDIR
 
 RDEPENDS = "python-core curl"