]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxslt: Fix unpackaged directory warning
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 13 Mar 2012 12:57:08 +0000 (12:57 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 13 Mar 2012 23:17:28 +0000 (23:17 +0000)
Fixes the warning:

WARNING: For recipe libxslt, the following files/directories were installed but not shipped in any package:
WARNING:   /usr/lib/libxslt-plugins

It makes sense for the package to own the plugins directory.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/libxslt/libxslt_1.1.26.bb

index f3e806d9890b44f792ffb50d1d25a70791960a0f..8986e207234702d7a2fe191e6e92154bcd3bcfb9 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
 
 SECTION = "libs"
 DEPENDS = "libxml2"
-PR = "r6"
+PR = "r7"
 
 SRC_URI = "ftp://xmlsoft.org/libxslt//libxslt-${PV}.tar.gz \
            file://pkgconfig_fix.patch"
@@ -24,6 +24,7 @@ RPROVIDES_${PN}-bin += "${PN}-utils"
 RCONFLICTS_${PN}-bin += "${PN}-utils"
 RREPLACES_${PN}-bin += "${PN}-utils"
 
+FILES_${PN} += "${libdir}/libxslt-plugins"
 FILES_${PN}-dev += "${libdir}/xsltConf.sh"
 
 BBCLASSEXTEND = "native"