]> code.ossystems Code Review - openembedded-core.git/commitdiff
pkgconfig: Remove custom do_configure from pkgconfig-native, tweak autofoo.patch...
authorRichard Purdie <richard@openedhand.com>
Mon, 14 Apr 2008 23:00:52 +0000 (23:00 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 14 Apr 2008 23:00:52 +0000 (23:00 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4262 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/pkgconfig/pkgconfig-0.23/autofoo.patch
meta/packages/pkgconfig/pkgconfig-native_0.23.bb
meta/packages/pkgconfig/pkgconfig.inc
meta/packages/pkgconfig/pkgconfig_0.23.bb

index 9a78f3bfd03f2dca07edc87bf4ab5b5374c37cdc..97895387f527bed6756a502112fe7d0c90ea3d6c 100644 (file)
@@ -511,3 +511,16 @@ Index: pkg-config-0.23/glib-1.2.10/configure.in
  
  
        if cmp -s $outfile glibconfig.h; then
+Index: pkg-config-0.23/glib-1.2.10/glib.m4
+===================================================================
+--- pkg-config-0.23.orig/glib-1.2.10/glib.m4   2008-04-14 23:34:39.000000000 +0100
++++ pkg-config-0.23/glib-1.2.10/glib.m4        2008-04-14 09:26:29.000000000 +0100
+@@ -5,7 +5,7 @@
+ dnl Test for GLIB, and define GLIB_CFLAGS and GLIB_LIBS, if "gmodule" or 
+ dnl gthread is specified in MODULES, pass to glib-config
+ dnl
+-AC_DEFUN(AM_PATH_GLIB,
++AC_DEFUN([AM_PATH_GLIB],
+ [dnl 
+ dnl Get the cflags and libraries from the glib-config script
+ dnl
index d167bd7699994b0756f80f107b2bcd19f1735aea..24497a9866223d60076ba263c2e3497415bd418b 100644 (file)
@@ -4,9 +4,3 @@ FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/pkgconfig-${PV}"
 S = "${WORKDIR}/pkg-config-${PV}/"
 inherit native
 DEPENDS = ""
-
-do_configure() {
-        gnu-configize
-       libtoolize --force
-       oe_runconf
-}
index 6fec0c3645d2e6088c6acbbe3315b6076a190cc8..58c6f90f19cd0f653ae3e6879b8eed25562d3ae9 100644 (file)
@@ -5,9 +5,10 @@ It replaces the ubiquitous *-config scripts you may have \
 seen with a single tool."
 HOMEPAGE = "http://pkg-config.freedesktop.org/wiki/"
 LICENSE = "GPL"
-PR = "r6"
+PR = "r7"
 
 SRC_URI = "http://pkgconfig.freedesktop.org/releases/pkg-config-${PV}.tar.gz \
+           file://autofoo.patch;patch=1 \
            file://sysrootfix.patch;patch=1 \
            file://glibconfig-sysdefs.h"
 
index 39fdc30f2cf92dd98994a80f74e1c8a1fb021a9b..10ce0fc9c303c1135425b60ddfc0aa9d6fe7b787 100644 (file)
@@ -1,6 +1,4 @@
 require pkgconfig.inc
 
-SRC_URI += "file://autofoo.patch;patch=1"
-
 DEPENDS += "glib-2.0"
 EXTRA_OECONF = "--with-installed-glib"