]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: Create packageconfig for ldconfig support
authorKhem Raj <raj.khem@gmail.com>
Thu, 5 Mar 2015 01:23:49 +0000 (01:23 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 9 Mar 2015 16:05:05 +0000 (16:05 +0000)
Useful when we disable ldconfig in glibc, we need to be able to
turn it off in systemd too, otherwise systemd tries to launch
the service and it fails

Change-Id: I170307f809a13def0cafc282e88d4eafa0313c31
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/systemd/systemd_219.bb

index 95b3f49148c57944a65cae226aea17a6e8f6ce03..454268a33a4bb4d825e46ac282b6d9872a64658d 100644 (file)
@@ -58,7 +58,7 @@ LDFLAGS_append_libc-uclibc = " -lrt"
 
 GTKDOC_DOCDIR = "${S}/docs/"
 
-PACKAGECONFIG ??= "xz \
+PACKAGECONFIG ??= "xz ldconfig \
                    ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \
                    ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xkbcommon', '', d)}"
 
@@ -83,6 +83,7 @@ PACKAGECONFIG[pam] = "--enable-pam,--disable-pam,libpam"
 PACKAGECONFIG[xkbcommon] = "--enable-xkbcommon,--disable-xkbcommon,libxkbcommon"
 # Update NAT firewall rules
 PACKAGECONFIG[iptc] = "--enable-libiptc,--disable-libiptc,iptables"
+PACKAGECONFIG[ldconfig] = "--enable-ldconfig,--disable-ldconfig,,"
 
 CACHED_CONFIGUREVARS = "ac_cv_path_KILL=${base_bindir}/kill"