]> code.ossystems Code Review - openembedded-core.git/commitdiff
udev: improved mount.sh
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 8 Aug 2008 07:41:48 +0000 (07:41 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 8 Aug 2008 07:41:48 +0000 (07:41 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5025 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/udev/files/akita/mount.blacklist
meta/packages/udev/files/c7x0/mount.blacklist
meta/packages/udev/files/mount.sh
meta/packages/udev/files/spitz/mount.blacklist
meta/packages/udev/files/tosa/mount.blacklist
meta/packages/udev/udev_124.bb

index 7e351bc98852a5054e6df2409d62095846f3b40d..c15b58229864b8ac4b1812c881de9df6b3956bfb 100644 (file)
@@ -1,6 +1,3 @@
-# This is a grep pattern matched against the device name
-# Any matched pattern will _not_ be mounted / removed by udevd
-
 /dev/mtdblock
 /dev/loop
-/dev/ram
\ No newline at end of file
+/dev/ram
index 7e351bc98852a5054e6df2409d62095846f3b40d..c15b58229864b8ac4b1812c881de9df6b3956bfb 100644 (file)
@@ -1,6 +1,3 @@
-# This is a grep pattern matched against the device name
-# Any matched pattern will _not_ be mounted / removed by udevd
-
 /dev/mtdblock
 /dev/loop
-/dev/ram
\ No newline at end of file
+/dev/ram
index 0ce1dc72175b55a2a9a5f53e006367f43942f5f5..53fefa368103ce00cfee32a37125344f6895f3e3 100644 (file)
@@ -9,9 +9,9 @@ MOUNT="/bin/mount"
 PMOUNT="/usr/bin/pmount"
 UMOUNT="/bin/umount"
 
-for line in `grep -v ^# /etc/udev/mount.blacklist`
+for line in `cat /etc/udev/mount.blacklist`
 do
-       if { echo "$DEVNAME" | grep -q "$line" ; }
+       if [ ` expr match "$DEVNAME" "$line" ` -gt 0 ];
        then
                logger "udev/mount.sh" "[$DEVNAME] is blacklisted, ignoring"
                exit 0
index 38c7aa4b324cf0c5771187d2bcfeacb33775ff13..aee308f9b80199cc45188a79405f74c3ff95a854 100644 (file)
@@ -1,7 +1,4 @@
-# This is a grep pattern matched against the device name
-# Any matched pattern will _not_ be mounted / removed by udevd
-
 /dev/mtdblock
 /dev/hda
 /dev/loop
-/dev/ram
\ No newline at end of file
+/dev/ram
index 7e351bc98852a5054e6df2409d62095846f3b40d..c15b58229864b8ac4b1812c881de9df6b3956bfb 100644 (file)
@@ -1,6 +1,3 @@
-# This is a grep pattern matched against the device name
-# Any matched pattern will _not_ be mounted / removed by udevd
-
 /dev/mtdblock
 /dev/loop
-/dev/ram
\ No newline at end of file
+/dev/ram
index e0f694565c457183cf58eecfdbbbac18ae91de5e..db8de02efd279c8f950103eb50cf009adc12142c 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
 the hotplug package and requires a kernel not older than 2.6.12."
 RPROVIDES_${PN} = "hotplug"
 
-PR = "r5"
+PR = "r6"
 
 SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
           file://noasmlinkage.patch;patch=1 \