]> code.ossystems Code Review - openembedded-core.git/commitdiff
util-linux: Update to 2.21
authorSaul Wold <sgw@linux.intel.com>
Mon, 27 Feb 2012 08:45:48 +0000 (00:45 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 28 Feb 2012 12:14:49 +0000 (12:14 +0000)
This updates various checksums for the COPYING files, which moved in the process
no changes to Licenses

Tweak the scanf_cv_alloc_modifier and rebase the patch

Signed-off-by: Saul Wold <sgw@linux.intel.com>
13 files changed:
meta/recipes-core/util-linux/util-linux-2.20.1/util-linux-ng-replace-siginterrupt.patch [deleted file]
meta/recipes-core/util-linux/util-linux-2.21/MCONFIG [moved from meta/recipes-core/util-linux/util-linux-2.20.1/MCONFIG with 100% similarity]
meta/recipes-core/util-linux/util-linux-2.21/defines.h [moved from meta/recipes-core/util-linux/util-linux-2.20.1/defines.h with 100% similarity]
meta/recipes-core/util-linux/util-linux-2.21/make_include [moved from meta/recipes-core/util-linux/util-linux-2.20.1/make_include with 100% similarity]
meta/recipes-core/util-linux/util-linux-2.21/remove-lscpu.patch [moved from meta/recipes-core/util-linux/util-linux-2.20.1/remove-lscpu.patch with 100% similarity]
meta/recipes-core/util-linux/util-linux-2.21/remove_sigsetmark.patch [moved from meta/recipes-core/util-linux/util-linux-2.20.1/remove_sigsetmark.patch with 100% similarity]
meta/recipes-core/util-linux/util-linux-2.21/swapargs.h [moved from meta/recipes-core/util-linux/util-linux-2.20.1/swapargs.h with 100% similarity]
meta/recipes-core/util-linux/util-linux-2.21/uclibc-__progname-conflict.patch [moved from meta/recipes-core/util-linux/util-linux-2.20.1/uclibc-__progname-conflict.patch with 100% similarity]
meta/recipes-core/util-linux/util-linux-2.21/uclibc-compile.patch [moved from meta/recipes-core/util-linux/util-linux-2.20.1/uclibc-compile.patch with 100% similarity]
meta/recipes-core/util-linux/util-linux-2.21/util-linux-ng-2.16-mount_lock_path.patch [moved from meta/recipes-core/util-linux/util-linux-2.20.1/util-linux-ng-2.16-mount_lock_path.patch with 100% similarity]
meta/recipes-core/util-linux/util-linux-2.21/util-linux-ng-replace-siginterrupt.patch [new file with mode: 0644]
meta/recipes-core/util-linux/util-linux.inc
meta/recipes-core/util-linux/util-linux_2.21.bb [moved from meta/recipes-core/util-linux/util-linux_2.20.1.bb with 84% similarity]

diff --git a/meta/recipes-core/util-linux/util-linux-2.20.1/util-linux-ng-replace-siginterrupt.patch b/meta/recipes-core/util-linux/util-linux-2.20.1/util-linux-ng-replace-siginterrupt.patch
deleted file mode 100644 (file)
index c5c0aff..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-Upstream-Status: Pending
-
-Index: util-linux-ng-2.14/login-utils/login.c
-===================================================================
---- util-linux-ng-2.14.orig/login-utils/login.c        2008-05-28 16:01:02.000000000 -0700
-+++ util-linux-ng-2.14/login-utils/login.c     2009-03-04 18:31:42.000000000 -0800
-@@ -358,6 +358,7 @@
-     char *childArgv[10];
-     char *buff;
-     int childArgc = 0;
-+    struct sigaction act;
- #ifdef HAVE_SECURITY_PAM_MISC_H
-     int retcode;
-     pam_handle_t *pamh = NULL;
-@@ -373,7 +374,9 @@
-     pid = getpid();
-     signal(SIGALRM, timedout);
--    siginterrupt(SIGALRM,1);           /* we have to interrupt syscalls like ioclt() */
-+    (void) sigaction(SIGALRM, NULL, &act);
-+    act.sa_flags &= ~SA_RESTART;
-+    sigaction(SIGALRM, &act, NULL);
-     alarm((unsigned int)timeout);
-     signal(SIGQUIT, SIG_IGN);
-     signal(SIGINT, SIG_IGN);
diff --git a/meta/recipes-core/util-linux/util-linux-2.21/util-linux-ng-replace-siginterrupt.patch b/meta/recipes-core/util-linux/util-linux-2.21/util-linux-ng-replace-siginterrupt.patch
new file mode 100644 (file)
index 0000000..ef56048
--- /dev/null
@@ -0,0 +1,26 @@
+Upstream-Status: Pending
+
+Index: util-linux-2.21/login-utils/login.c
+===================================================================
+--- util-linux-2.21.orig/login-utils/login.c
++++ util-linux-2.21/login-utils/login.c
+@@ -1216,6 +1216,8 @@ int main(int argc, char **argv)
+       char *buff;
+       int childArgc = 0;
+       int retcode;
++      struct sigaction act;
++
+       char *pwdbuf = NULL;
+       struct passwd *pwd = NULL, _pwd;
+@@ -1229,7 +1231,9 @@ int main(int argc, char **argv)
+       timeout = getlogindefs_num("LOGIN_TIMEOUT", LOGIN_TIMEOUT);
+       signal(SIGALRM, timedout);
+-      siginterrupt(SIGALRM, 1);       /* we have to interrupt syscalls like ioclt() */
++      (void) sigaction(SIGALRM, NULL, &act);
++      act.sa_flags &= ~SA_RESTART;
++      sigaction(SIGALRM, &act, NULL);
+       alarm((unsigned int)timeout);
+       signal(SIGQUIT, SIG_IGN);
+       signal(SIGINT, SIG_IGN);
index f60f33b9227b01cff6826cb729d37afb0ac796a5..1a3d293fd6bcff3c5bb4401688f2d5b56bdc8a85 100644 (file)
@@ -9,9 +9,11 @@ LICENSE = "GPLv2+ & LGPLv2.1+ & BSD"
 
 LIC_FILES_CHKSUM = "file://README.licensing;md5=9c920d811858a74b67a36ba23cbaa95f \
                     file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
-                    file://licenses/COPYING.GPL;md5=8ca43cbc842c2336e835926c2166c28b \
-                    file://licenses/COPYING.UCB;md5=263860f8968d8bafa5392cab74285262 \
-                    file://getopt/COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
+                    file://Documentation/licenses/COPYING.GPLv2;md5=8ca43cbc842c2336e835926c2166c28b \
+                    file://Documentation/licenses/COPYING.LGPLv2.1;md5=bbb461211a33b134d42ed5ee802b37ff \
+                    file://Documentation/licenses/COPYING.BSD-3;md5=58dcd8452651fc8b07d1f65ce07ca8af \
+                    file://Documentation/licenses/COPYING.UCB;md5=263860f8968d8bafa5392cab74285262 \
+                    file://getopt/COPYING;md5=c3a41733416fb80af7ba1b7e1f712551"
 
 inherit autotools gettext pkgconfig
 DEPENDS = "zlib ncurses"
similarity index 84%
rename from meta/recipes-core/util-linux/util-linux_2.20.1.bb
rename to meta/recipes-core/util-linux/util-linux_2.21.bb
index ed445d7e692d24e959f77b307207e0c50d1381fc..aa6ac649a37ac6f4ae2328487e1744aaaf56e1d4 100644 (file)
@@ -1,5 +1,5 @@
-MAJOR_VERSION = "2.20"
-PR = "r2"
+MAJOR_VERSION = "2.21"
+PR = "r0"
 require util-linux.inc
 
 # note that `lscpu' is under GPLv3+
@@ -10,15 +10,15 @@ SRC_URI += "file://util-linux-ng-replace-siginterrupt.patch \
             file://uclibc-__progname-conflict.patch \      
 "
 
-SRC_URI[md5sum] = "079b37517fd4e002a2e6e992e8b4e361"
-SRC_URI[sha256sum] = "d16ebcda3e64ab88ed363d9c1242cdb7ccfd5e1f56c83d0c3b0638c23793bbe0"
+SRC_URI[md5sum] = "3c7a26963f3921c1e775a80330321870"
+SRC_URI[sha256sum] = "2813ae6fe0449b60402e122c2baf97f26aa53e6e2dd05591c6cbcdf67ffdb6c6"
 
 # Only lscpu part is gplv3; rest of the code is not, 
 # so take out the lscpu parts while running non-gplv3 build.
 python () {
     d.setVar("REMOVELSCPU", "no")
     if (d.getVar("INCOMPATIBLE_LICENSE", True) or "").find("GPLv3") != -1:
-        # avoid GPLv3 
+        # avoid GPLv3
         d.setVar("REMOVELSCPU", "yes")
         packages = (d.getVar("PACKAGES", False) or "").split()
         if "util-linux-lscpu" in packages:
@@ -39,7 +39,7 @@ do_remove_lscpu() {
 
 addtask remove_lscpu before do_configure after do_patch
 
-CACHED_CONFIGUREVARS += "scanf_cv_type_modifier=as"
+CACHED_CONFIGUREVARS += "scanf_cv_alloc_modifier=as"
 EXTRA_OECONF_virtclass-native += "--disable-fallocate --disable-use-tty-group"
 
 do_install_append () {