]> code.ossystems Code Review - openembedded-core.git/commitdiff
kexec-tools: Fix synatx error with recent autoconf+automake
authorRichard Purdie <rpurdie@linux.intel.com>
Tue, 2 Feb 2010 16:21:56 +0000 (16:21 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 2 Feb 2010 16:21:56 +0000 (16:21 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/kexec/kexec-tools-1.101/configurefix.patch [new file with mode: 0644]
meta/packages/kexec/kexec-tools.inc
meta/packages/kexec/kexec-tools_1.101.bb

diff --git a/meta/packages/kexec/kexec-tools-1.101/configurefix.patch b/meta/packages/kexec/kexec-tools-1.101/configurefix.patch
new file mode 100644 (file)
index 0000000..60c55f0
--- /dev/null
@@ -0,0 +1,45 @@
+Index: kexec-tools-1.101/configure.ac
+===================================================================
+--- kexec-tools-1.101.orig/configure.ac        2010-02-02 15:14:43.173906722 +0000
++++ kexec-tools-1.101/configure.ac     2010-02-02 15:15:07.623910565 +0000
+@@ -100,23 +100,23 @@
+ BUILD_CFLAGS='-O2 -Wall $(CPPFLAGS)'
+ dnl ---Sanity checks
+-if test "$CC"      = "no"; then AC_MSG_ERROR([cc not found]) fi
+-if test "$CPP"     = "no"; then AC_MSG_ERROR([cpp not found]) fi
+-if test "$LD"      = "no"; then AC_MSG_ERROR([ld not found]) fi
+-if test "$AS"      = "no"; then AC_MSG_ERROR([as not found]) fi
+-if test "$OBJCOPY" = "no"; then       AC_MSG_ERROR([objcopy not found]) fi
+-if test "$AR"      = "no"; then       AC_MSG_ERROR([ar not found]) fi
+-
+-if test "$MKDIR"   = "no"; then AC_MSG_ERROR([ mkdir not found]) fi 
+-if test "$RM"      = "no"; then AC_MSG_ERROR([ rm not found]) fi    
+-if test "$CP"      = "no"; then AC_MSG_ERROR([ cp not found]) fi    
+-if test "$LN"      = "no"; then AC_MSG_ERROR([ ln not found]) fi    
+-if test "$TAR"     = "no"; then AC_MSG_ERROR([ tar not found]) fi   
+-if test "$RPM"     = "no"; then AC_MSG_ERROR([ rpm not found]) fi   
+-if test "$SED"     = "no"; then AC_MSG_ERROR([ sed not found]) fi   
+-if test "$FIND"    = "no"; then AC_MSG_ERROR([ find not found]) fi  
+-if test "$XARGS"   = "no"; then AC_MSG_ERROR([ xargs not found]) fi 
+-if test "$DIRNAME" = "no"; then AC_MSG_ERROR([ dirname not found]) fi 
++if test "$CC"      = "no"; then AC_MSG_ERROR([cc not found]); fi
++if test "$CPP"     = "no"; then AC_MSG_ERROR([cpp not found]); fi
++if test "$LD"      = "no"; then AC_MSG_ERROR([ld not found]); fi
++if test "$AS"      = "no"; then AC_MSG_ERROR([as not found]); fi
++if test "$OBJCOPY" = "no"; then       AC_MSG_ERROR([objcopy not found]); fi
++if test "$AR"      = "no"; then       AC_MSG_ERROR([ar not found]); fi
++
++if test "$MKDIR"   = "no"; then AC_MSG_ERROR([ mkdir not found]); fi 
++if test "$RM"      = "no"; then AC_MSG_ERROR([ rm not found]); fi    
++if test "$CP"      = "no"; then AC_MSG_ERROR([ cp not found]); fi    
++if test "$LN"      = "no"; then AC_MSG_ERROR([ ln not found]); fi    
++if test "$TAR"     = "no"; then AC_MSG_ERROR([ tar not found]); fi   
++if test "$RPM"     = "no"; then AC_MSG_ERROR([ rpm not found]); fi   
++if test "$SED"     = "no"; then AC_MSG_ERROR([ sed not found]); fi   
++if test "$FIND"    = "no"; then AC_MSG_ERROR([ find not found]); fi  
++if test "$XARGS"   = "no"; then AC_MSG_ERROR([ xargs not found]); fi 
++if test "$DIRNAME" = "no"; then AC_MSG_ERROR([ dirname not found]); fi 
+ dnl ---Output variables...
index 38919b3ff5c095a03b152dca173eead4aea18b92..8b8c70af679f00df5ef2b9c5466dcf53243205a1 100644 (file)
@@ -12,4 +12,5 @@ COMPATIBLE_HOST = '(x86_64|i.86.*|arm.*)-(linux|freebsd.*)'
 SRC_URI = "http://www.xmission.com/~ebiederm/files/kexec/kexec-tools-${PV}.tar.gz \
            file://kexec-tools-arm.patch;patch=1 \
            file://kexec-arm-atags.patch;patch=1 \
-           file://recentheader.patch;patch=1"
+           file://recentheader.patch;patch=1 \
+           file://configurefix.patch;patch=1"
index 17e8a41dc1ba59f9c106c288ed4e8cf7a8a21a81..949f22cf1f40486a69202a3dccf65e930a46658c 100644 (file)
@@ -2,4 +2,4 @@ require kexec-tools.inc
 export LDFLAGS = "-L${STAGING_LIBDIR}"
 EXTRA_OECONF = " --with-zlib=yes"
 
-PR = "r7"
+PR = "r8"