]> code.ossystems Code Review - openembedded-core.git/commitdiff
parted: improve ptest
authorRoss Burton <ross@burtonini.com>
Thu, 1 Oct 2020 16:11:11 +0000 (17:11 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 6 Oct 2020 22:12:50 +0000 (23:12 +0100)
Add a RRECOMMENDS on kernel-module-scsi-debug as this module is needed
for many of the tests.

Create the udev mount blacklist directory before writing into it, as it
doesn't always exist.

Delete any existing log files before calling make, as otherwise the
tests cannot be repeated.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/parted/files/run-ptest
meta/recipes-extended/parted/parted_3.3.bb

index f39c478ce6ab917732555dc2d056e439d2b19e3e..374f1bfbc9b1abc287f25d642fa4b7fdcb3d1844 100644 (file)
@@ -1,5 +1,7 @@
 #!/bin/sh
 
+mkdir -p /etc/udev/mount.blacklist.d
 echo /dev/sda1 >> /etc/udev/mount.blacklist.d/parted-tmp
+rm -f *.log
 make -C tests test-suite.log
 rm /etc/udev/mount.blacklist.d/parted-tmp
index aa4d8042cf85481fd41dbf30e13905fffc0e2df0..a1fd3ef07bf66c251910926341e7d436d44ebd97 100644 (file)
@@ -46,7 +46,7 @@ do_install_ptest() {
 }
 
 RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python3 make gawk e2fsprogs-mke2fs"
-
+RRECOMMENDS_${PN}-ptest = "kernel-module-scsi-debug"
 RDEPENDS_${PN}-ptest_append_libc-glibc = "\
         glibc-utils \
         locale-base-en-us \