]> code.ossystems Code Review - openembedded-core.git/commitdiff
openssh: upgrade 7.8p1 -> 7.8p1+git to support openssl 1.1.x
authorHongxu Jia <hongxu.jia@windriver.com>
Wed, 19 Sep 2018 11:59:29 +0000 (19:59 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 19 Sep 2018 13:28:26 +0000 (06:28 -0700)
- Convert from tarball to git repository which support
  openssl 1.1.x

- There is no specific minor version that contains the
  openssl fix (it was merged to master a few days agao),
  rename recipe version to `7.8p1+git'

- Fix regression test binaries missing
  In commit `1f7aaf7 openssh: build regression test binaries', it build
  regression test binaries, since upstream add two binaries in commits
  `c59aca8 Create control sockets in clean temp directories' and
  `1acc058 Disable tests where fs perms are incorrect', we should update
  do_compile_ptest.

  [ptest log]
  |/usr/lib/openssh/ptest/regress/test-exec.sh: line 330: /usr/lib/openssh/
  ptest/regress/mkdtemp: No such file or directory
  [ptest log]

Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/openssh/openssh_7.8p1+git.bb [moved from meta/recipes-connectivity/openssh/openssh_7.8p1.bb with 94% similarity]

similarity index 94%
rename from meta/recipes-connectivity/openssh/openssh_7.8p1.bb
rename to meta/recipes-connectivity/openssh/openssh_7.8p1+git.bb
index f4b295f2dfc833387b795196ea1acb1ff7b619b5..f54dfb5de448f384ae9921f2193dbf0cbe4514db 100644 (file)
@@ -8,11 +8,10 @@ SECTION = "console/network"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://LICENCE;md5=429658c6612f3a9b1293782366ab29d8"
 
-# openssl 1.1 patches are proposed at https://github.com/openssh/openssh-portable/pull/48
-DEPENDS = "zlib openssl10"
+DEPENDS = "zlib openssl"
 DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
 
-SRC_URI = "http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.gz \
+SRC_URI = "git://github.com/openssh/openssh-portable;branch=master \
            file://sshd_config \
            file://ssh_config \
            file://init \
@@ -29,8 +28,9 @@ SRC_URI = "http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar
 
 PAM_SRC_URI = "file://sshd"
 
-SRC_URI[md5sum] = "ce1d090fa6239fd38eb989d5e983b074"
-SRC_URI[sha256sum] = "1a484bb15152c183bb2514e112aa30dd34138c3cfb032eee5490a66c507144ca"
+SRCREV = "cce8cbe0ed7d1ba3a575310e0b63c193326ae616"
+
+S = "${WORKDIR}/git"
 
 inherit useradd update-rc.d update-alternatives systemd
 
@@ -80,7 +80,8 @@ do_configure_prepend () {
 do_compile_ptest() {
         # skip regress/unittests/ binaries: this will silently skip
         # unittests in run-ptests which is good because they are so slow.
-        oe_runmake regress/modpipe regress/setuid-allowed regress/netcat
+        oe_runmake regress/modpipe regress/setuid-allowed regress/netcat \
+                   regress/check-perm regress/mkdtemp
 }
 
 do_install_append () {