]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: inherit distro_features_check
authorRobert Yang <liezhi.yang@windriver.com>
Wed, 20 Dec 2017 01:53:13 +0000 (09:53 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 4 Jan 2018 12:56:04 +0000 (12:56 +0000)
Use distro_features_check so that we can have a uniform controller.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/systemd/systemd-serialgetty.bb
meta/recipes-core/systemd/systemd_234.bb
meta/recipes-core/udev/eudev_3.2.2.bb

index d9347163b557426db2107ab8fe57096e587fe209..d67a3c91b4a691f77b177f5e671aeca65fa0ff68 100644 (file)
@@ -11,6 +11,10 @@ SRC_URI = "file://serial-getty@.service"
 
 S = "${WORKDIR}"
 
+# As this package is tied to systemd, only build it when we're also building systemd.
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "systemd"
+
 do_install() {
        if [ ! -z "${SERIAL_CONSOLES}" ] ; then
                default_baudrate=`echo "${SERIAL_CONSOLES}" | sed 's/\;.*//'`
@@ -43,10 +47,4 @@ do_install() {
 FILES_${PN} = "${systemd_unitdir}/system/*.service ${sysconfdir}"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-# As this package is tied to systemd, only build it when we're also building systemd.
-python () {
-    if not bb.utils.contains ('DISTRO_FEATURES', 'systemd', True, False, d):
-        raise bb.parse.SkipPackage("'systemd' not in DISTRO_FEATURES")
-}
-
 ALLOW_EMPTY_${PN} = "1"
index 9a10a318812916303f325fc6a9e4692eba520fd7..4132cdf40f786ce40e09f0bc2b19e86d876b81d9 100644 (file)
@@ -8,7 +8,11 @@ DEPENDS = "kmod intltool-native gperf-native acl readline libcap libcgroup util-
 
 SECTION = "base/shell"
 
-inherit useradd pkgconfig autotools perlnative update-rc.d update-alternatives qemu systemd ptest gettext bash-completion manpages
+inherit useradd pkgconfig autotools perlnative update-rc.d update-alternatives qemu systemd ptest gettext bash-completion manpages distro_features_check
+
+# As this recipe builds udev, respect systemd being in DISTRO_FEATURES so
+# that we don't build both udev and systemd in world builds.
+REQUIRED_DISTRO_FEATURES = "systemd"
 
 SRC_URI = "git://github.com/systemd/systemd.git;protocol=git \
            file://touchscreen.rules \
@@ -630,10 +634,3 @@ pkg_postinst_udev-hwdb () {
 pkg_prerm_udev-hwdb () {
        rm -f $D${sysconfdir}/udev/hwdb.bin
 }
-
-# As this recipe builds udev, respect systemd being in DISTRO_FEATURES so
-# that we don't build both udev and systemd in world builds.
-python () {
-    if not bb.utils.contains ('DISTRO_FEATURES', 'systemd', True, False, d):
-        raise bb.parse.SkipPackage("'systemd' not in DISTRO_FEATURES")
-}
index 70e3568dc26285e73c1517c0d2db65457a4817fa..d01104746df956f78070deae8f846182f20e347f 100644 (file)
@@ -23,7 +23,9 @@ SRC_URI = "http://dev.gentoo.org/~blueness/${BPN}/${BP}.tar.gz \
 SRC_URI[md5sum] = "41e19b70462692fefd072a3f38818b6e"
 SRC_URI[sha256sum] = "3e4c56ec2fc1854afd0a31f3affa48f922c62d40ee12a0c1a4b4f152ef5b0f63"
 
-inherit autotools update-rc.d qemu pkgconfig
+inherit autotools update-rc.d qemu pkgconfig distro_features_check
+
+CONFLICT_DISTRO_FEATURES = "systemd"
 
 EXTRA_OECONF = " \
     --sbindir=${base_sbindir} \
@@ -75,11 +77,6 @@ RDEPENDS_eudev-hwdb += "eudev"
 RPROVIDES_${PN} = "hotplug udev"
 RPROVIDES_eudev-hwdb += "udev-hwdb"
 
-python () {
-    if bb.utils.contains ('DISTRO_FEATURES', 'systemd', True, False, d):
-        raise bb.parse.SkipPackage("'systemd' in DISTRO_FEATURES")
-}
-
 PACKAGE_WRITE_DEPS += "qemu-native"
 pkg_postinst_eudev-hwdb () {
     if test -n "$D"; then