]> code.ossystems Code Review - openembedded-core.git/commitdiff
mtd-utils-native: Stage header files for yaffs2 (from OE)
authorRichard Purdie <richard@openedhand.com>
Wed, 7 Nov 2007 11:39:03 +0000 (11:39 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 7 Nov 2007 11:39:03 +0000 (11:39 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3092 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/mtd/mtd-utils-native.inc
meta/packages/mtd/mtd-utils_1.0.0+git.bb
meta/packages/mtd/mtd-utils_1.0.0.bb

index da9759f02fe06609515f81f8059ddfc1c099cf45..8ac4673524df21eae0d789bdbbedb442b5770426 100644 (file)
@@ -3,8 +3,12 @@ DEPENDS = "zlib-native lzo-native"
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/mtd-utils"
 
 do_stage () {
+        install -d ${STAGING_INCDIR}/mtd
+        for f in ${S}/include/mtd/*.h; do
+                install -m 0644 $f ${STAGING_INCDIR}/mtd/
+        done
         for binary in ${mtd_utils}; do
                 install -m 0755 $binary ${STAGING_BINDIR}
         done
 }
-                                                                       
\ No newline at end of file
+
index 96c71fdb78f7a2c62e68e6518c7f4f2b2e2a03b3..81eaefad74e366ed5405b15b21f050c6bd539647 100644 (file)
@@ -3,7 +3,7 @@ SECTION = "base"
 DEPENDS = "zlib lzo"
 HOMEPAGE = "http://www.linux-mtd.infradead.org/"
 LICENSE = "GPLv2"
-PR = "r5"
+PR = "r6"
 
 SRC_URI = "git://git.infradead.org/mtd-utils.git;protocol=git;tag=2a032bca585e27ceb0f293905718b416bc297ce2 \
            file://add-exclusion-to-mkfs-jffs2-git.patch;patch=1 \
index 0ebb47fb22996fe471796e195152647657002a89..9c493298f6270f2cfddb0c0f102181b3cca328ef 100644 (file)
@@ -3,7 +3,7 @@ SECTION = "base"
 DEPENDS = "zlib"
 HOMEPAGE = "http://www.linux-mtd.infradead.org/"
 LICENSE = "GPLv2"
-PR = "r0"
+PR = "r1"
 
 # RP/kergoth: Builds seem to break with recent mtd-utils
 # Can't pin down the exact problems