]> code.ossystems Code Review - openembedded-core.git/commitdiff
unzip: Explicitly set EXTRA_OEMAKE as required
authorMike Crowe <mac@mcrowe.com>
Fri, 5 Feb 2016 18:04:28 +0000 (18:04 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 10 Feb 2016 15:51:05 +0000 (15:51 +0000)
This recipe currently relies on EXTRA_OEMAKE having been set to
"-e MAKEFLAGS=" in bitbake.conf to operate. It is necessary to make this
explicit so that the default in bitbake.conf can be changed.

Signed-off-by: Mike Crowe <mac@mcrowe.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/unzip/unzip_6.0.bb

index 77057946233fac2a820ac382af59ae63e37f8704..9efe75628ac6aba5b83089220d1f044db1070da9 100644 (file)
@@ -30,7 +30,7 @@ S = "${WORKDIR}/unzip60"
 # Makefile and add CFLAGS.  Optimization will be overriden by unzip
 # configure to be -O3.
 #
-EXTRA_OEMAKE += "STRIP=true LF2='' \
+EXTRA_OEMAKE = "-e MAKEFLAGS= STRIP=true LF2='' \
                 'CF_NOOPT=-I. -Ibzip2 -DUNIX ${CFLAGS}'"
 
 export LD = "${CC}"