]> code.ossystems Code Review - openembedded-core.git/commitdiff
logging.bbclass: Enclose the tr string in quotes
authorJason Wessel <jason.wessel@windriver.com>
Tue, 20 Feb 2018 23:53:29 +0000 (15:53 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 24 Feb 2018 10:31:35 +0000 (10:31 +0000)
On some linux hosts image recipes will fail to build as follows:

ERROR: build-essential-0.3-r0 do_image_ext3: Usage: bbdebug [123] "message"
ERROR: build-essential-0.3-r0 do_image_ext3: Function failed: do_image_ext3 (log file is located at /opt/build/tmp/work/intel_corei7_64-wrs-linux/build-essential/0.3-r0/temp/log.do_image_ext3.43744)
ERROR: Logfile of failure stored in: /opt/build/tmp/work/intel_corei7_64-wrs-linux/build-essential/0.3-r0/temp/log.do_image_ext3.43744
ERROR: Task (/opt/layers/meta-overc/meta-build/recipes-core/images/build-essential_0.3.bb:do_image_ext3) failed with exit code '1'

Running with bitbake -v -v -v -D we get in the log file:
+ bbdebug 1 Executing 'dd if=/dev/zero of=/opt/build/tmp/work/intel_corei7_64-wrs-linux/build-essential/0.3-r0/deploy-build-essential-image-complete/build-essential-intel-corei7-64-20180220190510.rootfs.ext3 seek=484486 count=0 bs=1024'
+ USAGE='Usage: bbdebug [123] "message"'
+ '[' 3 -lt 2 ']'
+ DBGLVL=1
+ shift
++ echo 1

++ echo 1
++ tr -d t

++ tr -d t
+ NONDIGITS=1
+ '[' 1 ']'
+ bbfatal 'Usage: bbdebug [123] "message"'

The debug output tells us that the NONDIGITS check failed to remove
the digits using the tr expression.  Enclosing the expression in
quotes causes it to work properly.

Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/classes/logging.bbclass

index 06c7c31c3ee63e712ec35a1017404e38766f9727..a0c94e98c73f51b4b819c8cb92e6f33d48f43618 100644 (file)
@@ -86,7 +86,7 @@ bbdebug() {
        
        # Strip off the debug level and ensure it is an integer
        DBGLVL=$1; shift
-       NONDIGITS=$(echo "$DBGLVL" | tr -d [:digit:])
+       NONDIGITS=$(echo "$DBGLVL" | tr -d "[:digit:]")
        if [ "$NONDIGITS" ]; then
                bbfatal "$USAGE"
        fi