]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu: When applying qemu-mips workaround, check the file exists first
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 8 Oct 2012 08:21:46 +0000 (09:21 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 8 Oct 2012 08:21:52 +0000 (09:21 +0100)
If qemu-mips was disabled as done in some distros, this wrapper would fail.
Therefore check if the file exists before wrapping it.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/qemu/qemu_1.2.0.bb

index cbdb4d472b4476991087d8ff19bb1612beaeea19..517a74b05ea9d30d0178118ef1b98d6e0e8629d1 100644 (file)
@@ -37,8 +37,10 @@ do_configure_prepend_virtclass-nativesdk() {
 # the qemu-mips works fine.
 # IMPORTANT: This piece needs to be removed once the root cause is fixed!
 do_install_append() {
-       create_wrapper ${D}/${bindir}/qemu-mips \
-               QEMU_RESERVED_VA=0x0
+       if [ -e "${D}/${bindir}/qemu-mips" ]; then
+               create_wrapper ${D}/${bindir}/qemu-mips \
+                       QEMU_RESERVED_VA=0x0
+       fi
 }
 # END of qemu-mips workaround