]> code.ossystems Code Review - openembedded-core.git/commitdiff
ghostscript: Disable parallel make due to install issues
authorSaul Wold <sgw@linux.intel.com>
Tue, 18 Oct 2011 16:44:27 +0000 (09:44 -0700)
committerSaul Wold <sgw@linux.intel.com>
Thu, 20 Oct 2011 02:58:45 +0000 (19:58 -0700)
ghostscript uses a script called instcopy to install files first
to temp dir and then rm's and copies dirs|files to the final destination.
When parallel make happens multiple threads of this runs and tries to
remove existing directories with contents, not a good thing, therefore
disable parallel make for install.

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/ghostscript/ghostscript_9.02.bb

index 9b21c669562b54be23b52ef4629264601406e7d6..1d48cce2b80d88ddeb45290e53988499d8669e13 100644 (file)
@@ -90,3 +90,7 @@ do_install_virtclass-native () {
 }
 
 BBCLASSEXTEND = "native"
+
+# Ghostscript install tool 'instcopy' tries to remove already created
+# directories during install and parallel make causes problems.
+PARALLEL_MAKEINST=""