]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3: do not replace ccache in the middle of a path
authorRoy Li <rongqing.li@windriver.com>
Wed, 22 Oct 2014 08:35:43 +0000 (16:35 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 4 Nov 2014 10:19:53 +0000 (10:19 +0000)
Python recipe did a sed s/ccache/$(CCACHE) on the Makefile, which
replaces all "ccache" including ones that consist of a full path.
This leads to build error when building in a project path with
"ccache" in its name. Fix it by only replacing "ccache " with
"$(CCACHE) ".

Same fix on python 2.xx is:
1181112cf65bc[python: do not replace ccache in the ]

Signed-off-by: Roy Li <rongqing.li@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/python/python3_3.3.3.bb

index a1cb12078f5c35e3145c671221d6f78afd148681..4497e02586918b252c58e8951603a0c31f4dc60d 100644 (file)
@@ -84,7 +84,7 @@ do_compile() {
         cd -
 
        # remove hardcoded ccache, see http://bugs.openembedded.net/show_bug.cgi?id=4144
-       sed -i -e s,ccache,'$(CCACHE)', Makefile
+       sed -i -e s,ccache\ ,'$(CCACHE) ', Makefile
 
        # remove any bogus LD_LIBRARY_PATH
        sed -i -e s,RUNSHARED=.*,RUNSHARED=, Makefile