]> code.ossystems Code Review - openembedded-core.git/commitdiff
libvorbis_1.3.1.bb: Fix recipe metadata
authorDongxiao Xu <dongxiao.xu@intel.com>
Sat, 26 Jun 2010 06:38:39 +0000 (14:38 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 30 Jun 2010 12:14:33 +0000 (13:14 +0100)
Add HOMEPAGE, BUGTRACKER, and LIC_FILES_CHKSUM
Adjust the variables order according to the styleguide
Use blank space to replace the tab

Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
meta/packages/libvorbis/libvorbis_1.3.1.bb

index 4145f1d0546acf89af8bb060e88e4bb5243c7b01..2181cb609a0b4a7bb18eef791024481a38177bc9 100644 (file)
@@ -1,9 +1,14 @@
-SECTION = "libs"
-DEPENDS = "libogg"
 DESCRIPTION = "Ogg Vorbis is a high-quality lossy audio codec \
 that is free of intellectual property restrictions. libvorbis \
 is the main vorbis codec library."
+HOMEPAGE = "http://xiph.org/"
+BUGTRACKER = "https://trac.xiph.org/newticket"
+SECTION = "libs"
 LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=ca77c6c3ea4d29cb68dce8ef5ab0d897 \
+                    file://include/vorbis/vorbisenc.h;beginline=1;endline=11;md5=d1c1d138863d6315131193d4046d81cb"
+DEPENDS = "libogg"
+
 PR = "r0"
 
 SRC_URI = "http://downloads.xiph.org/releases/vorbis/libvorbis-${PV}.tar.gz"
@@ -15,4 +20,4 @@ inherit autotools pkgconfig
 FULL_OPTIMIZATION_thumb = "-O0"
 
 EXTRA_OECONF = "--with-ogg-libraries=${STAGING_LIBDIR} \
-               --with-ogg-includes=${STAGING_INCDIR}"
+                --with-ogg-includes=${STAGING_INCDIR}"