]> code.ossystems Code Review - openembedded-core.git/commitdiff
nss-myhostname: add 0.3 version
authorMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
Thu, 14 Mar 2013 21:16:34 +0000 (22:16 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Mar 2013 13:17:34 +0000 (13:17 +0000)
Meta-linaro layer had own netbase.bbappend which took care of adding
MACHINE name to /etc/hosts to get it resolvable.

Koen Kooi pointed to nss-myhostname as better solution. Tested, works
fine so I add it for other users.

Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-support/nss-myhostname/nss-myhostname_0.3.bb [new file with mode: 0644]

diff --git a/meta/recipes-support/nss-myhostname/nss-myhostname_0.3.bb b/meta/recipes-support/nss-myhostname/nss-myhostname_0.3.bb
new file mode 100644 (file)
index 0000000..d5ed084
--- /dev/null
@@ -0,0 +1,25 @@
+DESCRIPTION = "plugin for the GNU Name Service Switch (NSS) functionality of \
+the GNU C Library (glibc) providing host name resolution for the locally \
+configured system hostname as returned by gethostname(2)."
+HOMEPAGE = "http://0pointer.de/lennart/projects/nss-myhostname/"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1"
+
+SRC_URI = "http://0pointer.de/lennart/projects/nss-myhostname/nss-myhostname-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "d4ab9ac36c053ab8fb836db1cbd4a48f"
+SRC_URI[sha256sum] = "2ba744ea8d578d1c57c85884e94a3042ee17843a5294434d3a7f6c4d67e7caf2"
+
+inherit autotools
+
+pkg_postinst_${PN} () {
+       sed -e '/^hosts:/s/\s*\<myhostname\>//' \
+               -e 's/\(^hosts:.*\)\(\<files\>\)\(.*\)\(\<dns\>\)\(.*\)/\1\2 myhostname \3\4\5/' \
+               -i $D/etc/nsswitch.conf
+}
+
+pkg_prerm_${PN} () {
+       sed -e '/^hosts:/s/\s*\<myhostname\>//' \
+               -e '/^hosts:/s/\s*myhostname//' \
+               -i $D/etc/nsswitch.conf
+}