]> code.ossystems Code Review - openembedded-core.git/commitdiff
openssh: allow the openssh meta package to be empty
authorScott Garman <scott.a.garman@intel.com>
Fri, 11 Mar 2011 00:06:16 +0000 (16:06 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 11 Mar 2011 02:34:06 +0000 (18:34 -0800)
This allows the openssh meta-package to be used in the
poky-ssh task. Otherwise there will be no package named
openssh to install during image creation.

Signed-off-by: Scott Garman <scott.a.garman@intel.com>
meta/recipes-connectivity/openssh/openssh_5.6p1.bb

index be9ae0973503f6f3297cf3502b4eed1ad7eeb890..d93a773f7ffd862d208598bdbbd687d21ddb6b62 100644 (file)
@@ -7,7 +7,7 @@ SECTION = "console/network"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://LICENCE;md5=7ae09218173be1643c998a4b71027f9b"
 
-PR = "r0"
+PR = "r1"
 
 DEPENDS = "zlib openssl"
 DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
@@ -67,6 +67,8 @@ do_install_append () {
        rmdir ${D}/var/run/sshd ${D}/var/run ${D}/var
 }
 
+ALLOW_EMPTY_${PN} = "1"
+
 PACKAGES =+ "${PN}-keygen ${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-sftp ${PN}-misc ${PN}-sftp-server"
 FILES_${PN}-scp = "${bindir}/scp.${PN}"
 FILES_${PN}-ssh = "${bindir}/ssh.${PN} ${sysconfdir}/ssh/ssh_config"