]> code.ossystems Code Review - openembedded-core.git/commitdiff
cups: refresh patches
authorRoss Burton <ross.burton@intel.com>
Fri, 9 Mar 2018 18:55:56 +0000 (20:55 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 11 Mar 2018 13:25:21 +0000 (06:25 -0700)
The patch tool will apply patches by default with "fuzz", which is where if the
hunk context isn't present but what is there is close enough, it will force the
patch in.

Whilst this is useful when there's just whitespace changes, when applied to
source it is possible for a patch applied with fuzz to produce broken code which
still compiles (see #10450).  This is obviously bad.

We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For
that to be realistic the existing patches with fuzz need to be rebased and
reviewed.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-extended/cups/cups/0001-don-t-try-to-run-generated-binaries.patch

index 5379eb6aa2b6710a433d115d10389143961564ea..db013cf08c447bb78c67b5621fefb3c981c9ce47 100644 (file)
@@ -10,12 +10,12 @@ Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
  ppdc/Makefile |   30 +++++++++++++++---------------
  1 files changed, 15 insertions(+), 15 deletions(-)
 
-Index: cups-2.0.0/ppdc/Makefile
+Index: cups-2.2.6/ppdc/Makefile
 ===================================================================
---- cups-2.0.0.orig/ppdc/Makefile
-+++ cups-2.0.0/ppdc/Makefile
-@@ -242,8 +242,8 @@ genstrings:                genstrings.o libcupsppdc.a
-       $(CXX) $(ARCHFLAGS) $(LDFLAGS) -o genstrings genstrings.o \
+--- cups-2.2.6.orig/ppdc/Makefile
++++ cups-2.2.6/ppdc/Makefile
+@@ -228,8 +228,8 @@ genstrings:                genstrings.o libcupsppdc.a
+       $(LD_CXX) $(ARCHFLAGS) $(LDFLAGS) -o genstrings genstrings.o \
                libcupsppdc.a ../cups/$(LIBCUPSSTATIC) $(LIBGSSAPI) $(SSLLIBS) \
                $(DNSSDLIBS) $(COMMONLIBS) $(LIBZ)
 -      echo Generating localization strings...
@@ -25,8 +25,8 @@ Index: cups-2.0.0/ppdc/Makefile
  
  
  #
-@@ -260,9 +260,9 @@ ppdc-static:               ppdc.o libcupsppdc.a ../cu
-       $(CXX) $(ARCHFLAGS) $(LDFLAGS) -o ppdc-static ppdc.o libcupsppdc.a \
+@@ -246,9 +246,9 @@ ppdc-static:               ppdc.o libcupsppdc.a ../cu
+       $(LD_CXX) $(ARCHFLAGS) $(LDFLAGS) -o ppdc-static ppdc.o libcupsppdc.a \
                ../cups/$(LIBCUPSSTATIC) $(LIBGSSAPI) $(SSLLIBS) $(DNSSDLIBS) \
                $(COMMONLIBS) $(LIBZ)
 -      echo Testing PPD compiler...
@@ -38,8 +38,8 @@ Index: cups-2.0.0/ppdc/Makefile
  
  
  #
-@@ -288,17 +288,17 @@ ppdi-static:             ppdc-static ppdi.o libcups
-       $(CXX) $(ARCHFLAGS) $(LDFLAGS) -o ppdi-static ppdi.o libcupsppdc.a \
+@@ -274,17 +274,17 @@ ppdi-static:             ppdc-static ppdi.o libcups
+       $(LD_CXX) $(ARCHFLAGS) $(LDFLAGS) -o ppdi-static ppdi.o libcupsppdc.a \
                ../cups/$(LIBCUPSSTATIC) $(LIBGSSAPI) $(SSLLIBS) $(DNSSDLIBS) \
                $(COMMONLIBS) $(LIBZ)
 -      echo Testing PPD importer...