]> code.ossystems Code Review - openembedded-core.git/commitdiff
glibc-package.inc: disable build-time locale generation for nativesdk
authorKevin Tian <kevin.tian@intel.com>
Fri, 3 Sep 2010 06:29:17 +0000 (14:29 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 3 Sep 2010 08:30:26 +0000 (09:30 +0100)
The idea of build-time locale generation is documented in glibc-package.inc:

    Binary locales are generated at build time if ENABLE_BINARY_LOCALE_GENERATION
    is set. The idea is to avoid running localedef on the target (at first boot)
    to decrease initial boot time and avoid localedef being killed by the OOM
    killer which used to effectively break i18n on machines with < 128MB RAM.

However it doesn't make sense to do same thing for glibc-nativesdk, as the
build system is powerful. More importantly is that ideally host_arch running
sdk may even be out of the support list of target_arch by qemu-native.

Regarding to above rationale, this commit disables build time locale
generation to avoid following error when asking qemu to run localdef:

NOTE: /opt/poky/sysroots/i586-pokysdk-linux/lib/ld-linux.so.2: No such file or directory

nativesdk binaris have opt path hardcoded to avoid mess with host bits, which
is another reason that build time locale generation is not feasible here.

This fixes [BUGID #264]

also add 'nativesdk' to eglibc per RP's suggestion

Signed-off-by: Kevin Tian <kevin.tian@intel.com>
meta/recipes-core/eglibc/eglibc-package.inc
meta/recipes-core/eglibc/eglibc_2.12.bb
meta/recipes-core/glibc/glibc-package.inc
meta/recipes-core/glibc/glibc_2.10.1.bb

index 01bda10dc12b665ea784dc5735f8f612db51cfb4..a315e05d65cca8bd99bf1da45d161deca4cf6131 100644 (file)
@@ -21,6 +21,7 @@ python __anonymous () {
 
 # default to disabled until qemu works for everyone
 ENABLE_BINARY_LOCALE_GENERATION ?= "0"
+ENABLE_BINARY_LOCALE_GENERATION_pn-eglibc-nativesdk = "0"
 
 # BINARY_LOCALE_ARCHES is a space separated list of regular expressions
 BINARY_LOCALE_ARCHES ?= "arm.* i[3-6]86 x86_64 powerpc mips"
index 45e1520792bf64438a2660290d953dfc2ba154eb..79ec6a399b359e97a6559af44530e1a85dc79e75 100644 (file)
@@ -2,7 +2,7 @@ require eglibc.inc
 
 DEPENDS += "gperf-native"
 FILESPATHPKG =. "eglibc-svn:"
-PR = "r2"
+PR = "r3"
 SRCREV="10809"
 EGLIBC_BRANCH="eglibc-2_12"
 SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http \
index 5c683bbe7dc6e4d5dc348346967f3226b4a0721f..9aaa4f3873d5271032b79a58647c12cb76f135d6 100644 (file)
@@ -22,6 +22,7 @@ python __anonymous () {
 
 # default to disabled until qemu works for everyone
 ENABLE_BINARY_LOCALE_GENERATION ?= "0"
+ENABLE_BINARY_LOCALE_GENERATION_pn-glibc-nativesdk = "0"
 
 # BINARY_LOCALE_ARCHES is a space separated list of regular expressions
 BINARY_LOCALE_ARCHES ?= "arm.* i[3-6]86 x86_64 powerpc mips"
index a82a87025628907fff6537b93975fa1e173b1d23..2b87186227bcb590c8d42c943fd07c3d8a21a0e9 100644 (file)
@@ -5,7 +5,7 @@ ARM_INSTRUCTION_SET = "arm"
 PACKAGES_DYNAMIC = "libc6*"
 RPROVIDES_${PN}-dev = "libc6-dev virtual-libc-dev"
 
-PR = "r2"
+PR = "r3"
 
 # the -isystem in bitbake.conf screws up glibc do_stage
 BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"