]> code.ossystems Code Review - openembedded-core.git/commitdiff
go: Remove three unnecessary paths from do_compile[dirs]
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>
Mon, 14 Mar 2022 14:16:47 +0000 (15:16 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 15 Mar 2022 08:38:28 +0000 (08:38 +0000)
There is no reason to include a path in foo[dirs] if it is also in
foo[cleandirs] (except if it is the last path in foo[dirs]).

Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/go/go-cross-canadian.inc
meta/recipes-devtools/go/go-cross.inc
meta/recipes-devtools/go/go-crosssdk.inc
meta/recipes-devtools/go/go-native_1.17.8.bb
meta/recipes-devtools/go/go-runtime.inc
meta/recipes-devtools/go/go-target.inc

index d49250a8e2e04595d253cfff8cb100c16fd36788..c1aa98742775de2e3f366cf13b84002e847156a9 100644 (file)
@@ -27,7 +27,6 @@ do_compile() {
        ./make.bash --host-only --no-banner
        cd ${B}
 }
-do_compile[dirs] =+ "${GOTMPDIR} ${B}/bin ${B}/pkg"
 do_compile[cleandirs] += "${GOTMPDIR} ${B}/bin ${B}/pkg"
 
 
index 3d5803bf07ae5ae691c0c772490fc229e8aadcdf..a0fbdbe3b9385f3572ff5bb3aec99087768931d7 100644 (file)
@@ -17,7 +17,6 @@ do_compile() {
        ./make.bash --host-only --no-banner
        cd ${B}
 }
-do_compile[dirs] =+ "${GOTMPDIR} ${B}/bin ${B}/pkg"
 do_compile[cleandirs] += "${GOTMPDIR} ${B}/bin ${B}/pkg"
 
 make_wrapper() {
index f0bec7971903f87c5cf039284a1315aaabc187ab..cd23cca2fe3fab32266b24d0693bc56d8d6d08f4 100644 (file)
@@ -13,7 +13,6 @@ do_compile() {
        ./make.bash --host-only --no-banner
        cd ${B}
 }
-do_compile[dirs] =+ "${GOTMPDIR} ${B}/bin ${B}/pkg"
 do_compile[cleandirs] += "${GOTMPDIR} ${B}/bin ${B}/pkg"
 
 make_wrapper() {
index ffe4ef35236c32f5dd66ddc48a03600711e0202f..76c0ab73a61afd64ade94de1311082a38934d5ae 100644 (file)
@@ -27,7 +27,6 @@ do_compile() {
        ./make.bash ${GOMAKEARGS}
        cd ${B}
 }
-do_compile[dirs] =+ "${GOTMPDIR} ${B}/bin"
 do_compile[cleandirs] += "${GOTMPDIR} ${B}/bin"
 
 make_wrapper() {
index ccb86d4fe9a69bd9a70d41d4733f1fe84073b9fe..e18339cddb0c5602a826922676e25dca2e8ace7b 100644 (file)
@@ -38,7 +38,6 @@ do_compile() {
        fi
        cd ${B}
 }
-do_compile[dirs] =+ "${GOTMPDIR} ${B}/bin ${B}/pkg"
 do_compile[cleandirs] += "${GOTMPDIR} ${B}/bin ${B}/pkg"
 
 do_install() {
index b0d487ae1c21831c29e10be97108df7f9a50a6d8..d085643036a146b6b824b49a54884c3841b8317b 100644 (file)
@@ -29,7 +29,6 @@ do_compile() {
        ./make.bash --target-only --no-banner
        cd ${B}
 }
-do_compile[dirs] =+ "${GOTMPDIR} ${B}/bin ${B}/pkg"
 do_compile[cleandirs] += "${GOTMPDIR} ${B}/bin ${B}/pkg"
 
 do_install() {