]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: Make it build with hwdb disabled
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>
Fri, 20 Sep 2019 07:25:27 +0000 (09:25 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 27 Sep 2019 12:01:17 +0000 (13:01 +0100)
If hwdb is disabled, then systemd-hwdb-update.service does not exists.
Do not try to modify it in this case.

Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/systemd/systemd_243.bb

index f0e8c569b81389c06c41bc7113b95fc2b25d5f5f..d0f9d17dba8406ad5040adec128be47fd06a26b5 100644 (file)
@@ -299,9 +299,10 @@ do_install() {
 }
 
 do_install_append () {
-       # Mips qemu is extremely slow, allow more time for the hwdb update
-       # This is a workaround until https://github.com/systemd/systemd/issues/13581 is resolved
-       sed -i -e s#TimeoutSec=90s#TimeoutSec=180s# ${D}${systemd_unitdir}/system/systemd-hwdb-update.service
+       # Mips qemu is extremely slow, allow more time for the hwdb update
+       # This is a workaround until https://github.com/systemd/systemd/issues/13581 is resolved
+       [ ! -e ${D}${systemd_unitdir}/system/systemd-hwdb-update.service ] ||
+               sed -i -e s#TimeoutSec=90s#TimeoutSec=180s# ${D}${systemd_unitdir}/system/systemd-hwdb-update.service
 }
 
 python populate_packages_prepend (){