]> code.ossystems Code Review - openembedded-core.git/commitdiff
gtk+: Updated filechooser size patch from Thomas
authorRichard Purdie <richard@openedhand.com>
Sun, 2 Mar 2008 17:14:51 +0000 (17:14 +0000)
committerRichard Purdie <richard@openedhand.com>
Sun, 2 Mar 2008 17:14:51 +0000 (17:14 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3885 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/gtk+/gtk+-2.12.7/filechooser-sizefix.patch
meta/packages/gtk+/gtk+_2.12.7.bb

index 4de68dfb98894495ff8952b6ba0c122375103542..694b059b9ae1d83dae691ae08a35ac738700bbd0 100644 (file)
@@ -1,21 +1,5 @@
-
-diff -ur /tmp/gtk+-2.12.7/gtk/gtkfilechooserdefault.c ./gtk/gtkfilechooserdefault.c
---- /tmp/gtk+-2.12.7/gtk/gtkfilechooserdefault.c       2008-02-29 17:00:14.000000000 +0000
-+++ ./gtk/gtkfilechooserdefault.c      2008-02-29 17:25:21.000000000 +0000
-@@ -178,8 +178,8 @@
- #define FALLBACK_ICON_SIZE 24
- #define LIST_HBOX_SPACING DEFAULT_SPACING
--#define NUM_LINES 45
--#define NUM_CHARS 60
-+#define NUM_LINES 10
-+#define NUM_CHARS 12
- static void gtk_file_chooser_default_iface_init       (GtkFileChooserIface        *iface);
- static void gtk_file_chooser_embed_default_iface_init (GtkFileChooserEmbedIface   *iface);
-diff -ur /tmp/gtk+-2.12.7/gtk/gtkfilechooserdialog.c ./gtk/gtkfilechooserdialog.c
---- /tmp/gtk+-2.12.7/gtk/gtkfilechooserdialog.c        2008-01-30 03:11:07.000000000 +0000
-+++ ./gtk/gtkfilechooserdialog.c       2008-02-29 17:20:30.000000000 +0000
+--- gtk+-2.12.7.orig/gtk/gtkfilechooserdialog.c 
++++ gtk+-2.12.7/gtk/gtkfilechooserdialog.c 
 @@ -165,10 +165,10 @@
    gdk_screen_get_monitor_geometry (screen, monitor_num, &monitor);
  
@@ -29,3 +13,23 @@ diff -ur /tmp/gtk+-2.12.7/gtk/gtkfilechooserdialog.c ./gtk/gtkfilechooserdialog.
  }
  
  static void
+@@ -183,6 +183,7 @@
+   priv = GTK_FILE_CHOOSER_DIALOG_GET_PRIVATE (dialog);
++#if 0
+   /* Unset any previously set size */
+   gtk_widget_set_size_request (GTK_WIDGET (dialog), -1, -1);
+@@ -209,6 +210,11 @@
+   /* Ideal target size plus any extra size */
+   width = default_width + width + (2 * GTK_CONTAINER (dialog)->border_width);
+   height = default_height + height + (2 * GTK_CONTAINER (dialog)->border_width);
++#endif
++
++  /* for small screens we just hard code a sensible value */
++  width = 350;
++  height = 350;
+   if (GTK_WIDGET_REALIZED (dialog))
+     clamp_to_screen (GTK_WIDGET (dialog), &width, &height);
index f66b4b80b2da256e58ae03e93886cd155f669fdf..1f3e6e394e80566e0d77c5a720c8505708bd31d0 100644 (file)
@@ -1,7 +1,7 @@
 require gtk+.inc
 
 DEPENDS += "cairo"
-PR = "r5"
+PR = "r6"
 
 SRC_URI = "http://download.gnome.org/sources/gtk+/2.12/gtk+-${PV}.tar.bz2 \
            file://xsettings.patch;patch=1 \