]> code.ossystems Code Review - openembedded-core.git/commitdiff
texinfo: fix compile failure due target makedoc binary being used
authorSaul Wold <sgw@linux.intel.com>
Sat, 10 Dec 2011 20:22:38 +0000 (12:22 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 12 Dec 2011 21:50:07 +0000 (21:50 +0000)
Need to have the texinfo-native build and install a host sysroot makedoc
binary and then patch the target build to use this binary. This requires
that we don't ASSUME_PROVIDED texinfo-native any longer since we need to
install this makedoc tool which is not part of the normal distrubtion.

[YOCTO #1664]

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/texinfo/texinfo-4.13a/use_host_makedoc.patch [new file with mode: 0644]
meta/recipes-extended/texinfo/texinfo_4.13a.bb

diff --git a/meta/recipes-extended/texinfo/texinfo-4.13a/use_host_makedoc.patch b/meta/recipes-extended/texinfo/texinfo-4.13a/use_host_makedoc.patch
new file mode 100644 (file)
index 0000000..db41f1a
--- /dev/null
@@ -0,0 +1,37 @@
+This patch requires that we also enable building of the
+texinfo-native recipe which will install the makedoc tool 
+for the host machine.
+
+This patch simply uses the newly installed makedoc tool from
+sysroot.
+
+Upstream-Status: Inappropriate [OE-Specific]
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: texinfo-4.13/info/Makefile.am
+===================================================================
+--- texinfo-4.13.orig/info/Makefile.am 2008-05-22 05:11:33.000000000 -0700
++++ texinfo-4.13/info/Makefile.am      2011-12-10 12:55:53.604440118 -0800
+@@ -75,7 +75,7 @@
+ # more than once.
+ funs.h: makedoc$(EXEEXT) $(cmd_sources)
+       rm -f $(generated_sources)
+-      $(top_builddir)/$(native_tools)/info/makedoc $(cmd_sources)
++      makedoc $(cmd_sources)
+ # The following hack is necessary to hint make before the automatic
+ # dependencies are built.
+Index: texinfo-4.13/doc/Makefile.am
+===================================================================
+--- texinfo-4.13.orig/doc/Makefile.am  2008-09-18 11:31:56.000000000 -0700
++++ texinfo-4.13/doc/Makefile.am       2011-12-10 13:04:09.216457601 -0800
+@@ -19,7 +19,7 @@
+ # Use the programs built in our distribution, taking account of possible
+ # cross-compiling.
+-MAKEINFO = $(top_builddir)/$(native_tools)/makeinfo/makeinfo
++MAKEINFO = makeinfo
+ # We'd also like to use something like this, but Automake calls
+ # "install-info" directly.
index 9f1c04ace1a86e4ba4559a312729459cadde7440..f205d4e04df055a53dc8d9d8a10ef44a648466cc 100644 (file)
@@ -6,11 +6,14 @@ HOMEPAGE = "http://www.gnu.org/software/texinfo/"
 SECTION = "console/utils"
 LICENSE = "GPLv3+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=adefda309052235aa5d1e99ce7557010"
-PR = "r1"
+PR = "r2"
 
 DEPENDS = "zlib ncurses texinfo-native"
 DEPENDS_virtclass-native = "zlib-native ncurses-native"
 
+TARGET_PATCH = "file://use_host_makedoc.patch"
+TARGET_PATCH_virtclass-native = ""
+
 SRC_URI = "${GNU_MIRROR}/texinfo/texinfo-${PV}.tar.gz \
            file://texinfo-4.12-zlib.patch \
            file://texinfo-4.13a-data_types.patch \
@@ -19,7 +22,8 @@ SRC_URI = "${GNU_MIRROR}/texinfo/texinfo-${PV}.tar.gz \
            file://texinfo-4.13a-help-index-segfault.patch \
            file://disable-native-tools.patch \
            file://link-zip.patch \
-           file://gettext-macros.patch"
+           file://gettext-macros.patch \
+           ${TARGET_PATCH}"
 
 SRC_URI[md5sum] = "71ba711519209b5fb583fed2b3d86fcb"
 SRC_URI[sha256sum] = "1303e91a1c752b69a32666a407e9fbdd6e936def4b09bc7de30f416301530d68"
@@ -39,6 +43,9 @@ do_install_append() {
        mkdir -p ${D}${datadir}/${tex_texinfo}
        install -p -m644 doc/texinfo.tex doc/txi-??.tex ${D}${datadir}/${tex_texinfo}   
 }
+do_install_append_virtclass-native() {
+       install -m 755 info/makedoc ${D}${bindir}
+}
 
 PACKAGES += "info info-doc"