]> code.ossystems Code Review - openembedded-core.git/commitdiff
sqlite3: Add support for column metadata API
authorAlex J Lennon <ajlennon@dynamicdevices.co.uk>
Wed, 6 Nov 2013 18:15:39 +0000 (18:15 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 8 Nov 2013 17:24:50 +0000 (17:24 +0000)
I found that Mono.Data.SQlite has a dependency on the column meta-data API, thus enabling this API enables use of Hibernate / Mono with SQLite and no doubt enables other ORMs / utility libraries.

ref: https://bugzilla.xamarin.com/show_bug.cgi?id=6333

The API is present in the used SQLite3 sqlite-autoconf-3080002 source-base. Thus we are enabling pre-existing SQLite support rather than introducing new code.

I am not aware of any issues that enabling this SQLite functionality introduces, other than a slightly increased library size of circa 1.5KB , i.e. coretexa9_vfp_neon i.MX6

- with column meta-data API        610360 libsqlite3.so.0.8.6
- without column meta-data API  608880 libsqlite3.so.0.8.6

Signed-off-by: Alex J Lennon <ajlennon@dynamicdevices.co.uk>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-support/sqlite/sqlite3_3080002.bb

index 91dc6dd49b678db9d446a34fd67029d65d9ef526..18ff292fc100d7bc724d4aa63896be79c2520336 100644 (file)
@@ -8,3 +8,8 @@ SRC_URI[md5sum] = "6d6cc639a4da04fbbdda7b1a1a01b386"
 SRC_URI[sha256sum] = "fca3a0a12f94dc92a6d9e700c3f6cab6cd4e79214bd7b6f13717a10f4bcfddb2"
 
 S = "${WORKDIR}/sqlite-autoconf-${PV}"
+
+# Provide column meta-data API
+BUILD_CFLAGS += "-DSQLITE_ENABLE_COLUMN_METADATA"
+TARGET_CFLAGS += "-DSQLITE_ENABLE_COLUMN_METADATA"
+