]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3-pygobject: enable cairo only when a display is available
authorAndré Draszik <adraszik@tycoint.com>
Tue, 17 Jan 2017 15:28:28 +0000 (15:28 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 19 Jan 2017 22:45:45 +0000 (22:45 +0000)
It doesn't seem to make sense to unconditionally enable cairo
support, as this pulls in lots of other dependencies, where
none of these can actually be used without some sort of
graphical interface.

Not having a generic distro feature to detect this, we just
use any of DirectFB / Wayland / X11

Signed-off-by: André Draszik <adraszik@tycoint.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/python/python3-pygobject_3.22.0.bb

index 5a895441fcae85ea0a2ca6e7180d39da3bb38ed8..143048d9ef24dbb1ee633150e1e2fa33753c925a 100644 (file)
@@ -19,7 +19,7 @@ SRC_URI[sha256sum] = "08b29cfb08efc80f7a8630a2734dec65a99c1b59f1e5771c671d2e4ed8
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
 
-PACKAGECONFIG ??= "cairo"
+PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}"
 
 # python3-pycairo is checked on configuration -> DEPENDS
 # we don't link against python3-pycairo -> RDEPENDS