]> code.ossystems Code Review - openembedded-core.git/commitdiff
apr-util: disable pqsql support to avoid configure error
authorMei Lei <lei.mei@intel.com>
Fri, 5 Aug 2011 01:52:15 +0000 (09:52 +0800)
committerSaul Wold <sgw@linux.intel.com>
Sat, 6 Aug 2011 20:40:44 +0000 (13:40 -0700)
The pqsql config script will check host path and add host paths to compiler and linker options:
adding "-I/usr/include/postgresql" to CPPFLAGS
adding "-L/usr/lib" to LDFLAGS

Disable pqsql support since we didn't use this feature in other recipes.

Signed-off-by: Mei Lei <lei.mei@intel.com>
meta/recipes-support/apr/apr-util_1.3.12.bb

index 6635202da50b3d248357f3d49ed2b30aa13bc93d..800e67e4cb8e5e17b83148d8c188cd9eeb043087 100644 (file)
@@ -7,7 +7,7 @@ LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=519e0a18e03f7c023070568c14b077bb \
                     file://include/apu_version.h;endline=17;md5=806685a84e71f10c80144c48eb35df42"
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "${APACHE_MIRROR}/apr/${BPN}-${PV}.tar.gz \
            file://configfix.patch \
@@ -18,6 +18,7 @@ SRC_URI[sha256sum] = "815b6fc82950f61050a5e711a7f3c20fd9b6ffcc7a4cacfe9f291fb241
 
 EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \ 
                --without-odbc \
+               --without-pgsql \
                --with-dbm=gdbm \
                --with-gdbm=${STAGING_DIR_HOST}${prefix} \
                --without-sqlite2 \