]> code.ossystems Code Review - openembedded-core.git/commitdiff
elfutils: fix builds with gcc 4.6
authorJoshua Lock <josh@linux.intel.com>
Wed, 30 Mar 2011 22:21:50 +0000 (23:21 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 4 Apr 2011 12:50:18 +0000 (13:50 +0100)
gcc 4.6 (as used in Fedora 15) adds some extra warnings which are
included with Werror. The new unused-but-set variable warning causes
an error in libasm of elfutils. Work around this by removing
unused-but-set from Werror.

Signed-off-by: Joshua Lock <josh@linux.intel.com>
meta/recipes-devtools/elfutils/elfutils_0.148.bb

index b2f700ede7d09397e0569de2160c18f4bf28fa16..c395be81dc638f6e7e4ff352e507a189829b06e5 100644 (file)
@@ -40,6 +40,10 @@ SRC_URI += "\
 
 inherit autotools
 
+# GCC 4.6.0 raises an unused-but-set warning in libasm, for now remove
+# this warning from Werror
+CFLAGS_virtclass-native += "-Wno-error=unused-but-set-variable"
+
 EXTRA_OECONF = "--program-prefix=eu-"
 
 do_configure_prepend() {